summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-17 06:24:32 +0000
committerSam James <sam@gentoo.org>2023-02-17 06:25:01 +0000
commit731c306909c9740025426bdc24a4d4a648887d62 (patch)
tree3b378aed48f7d92f093841263f3a33bf14d2169c /net-misc/httpstat
parentnet-misc/httpstat: enable py3.11 (diff)
downloadgentoo-731c306909c9740025426bdc24a4d4a648887d62.tar.gz
gentoo-731c306909c9740025426bdc24a4d4a648887d62.tar.bz2
gentoo-731c306909c9740025426bdc24a4d4a648887d62.zip
net-misc/httpstat: PEP517
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/httpstat')
-rw-r--r--net-misc/httpstat/Manifest1
-rw-r--r--net-misc/httpstat/httpstat-1.3.1-r1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/httpstat/Manifest b/net-misc/httpstat/Manifest
index 7628631d9551..6c21f9db0e5c 100644
--- a/net-misc/httpstat/Manifest
+++ b/net-misc/httpstat/Manifest
@@ -1 +1,2 @@
+DIST httpstat-1.3.1.gh.tar.gz 97691 BLAKE2B f7a5388c3891c1caac654c6c9be425864e2a037eba2e12229ec72c847864f7be23b64d5450ebb42f976335f5b6ca878f1ee555ee3b2178c1a10c5969f883604d SHA512 bca91afe14d50af37c741ca4baa7d3843b010bb6dc012c72bd28c43f59099c20628cadc4dd80652dffeb1d26fb07f5cf156a3f6bf9eba1f6e121d4b250020b46
DIST httpstat-1.3.1.tar.gz 97691 BLAKE2B f7a5388c3891c1caac654c6c9be425864e2a037eba2e12229ec72c847864f7be23b64d5450ebb42f976335f5b6ca878f1ee555ee3b2178c1a10c5969f883604d SHA512 bca91afe14d50af37c741ca4baa7d3843b010bb6dc012c72bd28c43f59099c20628cadc4dd80652dffeb1d26fb07f5cf156a3f6bf9eba1f6e121d4b250020b46
diff --git a/net-misc/httpstat/httpstat-1.3.1-r1.ebuild b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..da4d547a2347
--- /dev/null
+++ b/net-misc/httpstat/httpstat-1.3.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="httpstat visualizes cURL statistics in a way of beauty and clarity"
+HOMEPAGE="https://github.com/reorx/httpstat"
+SRC_URI="https://github.com/reorx/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-misc/curl:*"
+
+# Requires access to google.com and http2.akamai.com
+RESTRICT="test"
+PROPERTIES="test_network"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.2.1-gentoo-tests.patch )
+
+python_test() {
+ ./httpstat_test.sh || die
+}