summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:57:17 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:30:08 +0100
commit8cd2b4c8c0afc62d40af8e0d220ec9408698bd7f (patch)
tree6d7a86e39530954e2df43ac1f49ab4476215ad83 /net-misc/dhcp
parentnet-misc/asterisk: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-8cd2b4c8c0afc62d40af8e0d220ec9408698bd7f.tar.gz
gentoo-8cd2b4c8c0afc62d40af8e0d220ec9408698bd7f.tar.bz2
gentoo-8cd2b4c8c0afc62d40af8e0d220ec9408698bd7f.zip
net-misc/dhcp: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/dhcp')
-rw-r--r--net-misc/dhcp/dhcp-4.4.2_p1-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-misc/dhcp/dhcp-4.4.2_p1-r1.ebuild b/net-misc/dhcp/dhcp-4.4.2_p1-r1.ebuild
index 57fd8dd47f48..7ae208514c67 100644
--- a/net-misc/dhcp/dhcp-4.4.2_p1-r1.ebuild
+++ b/net-misc/dhcp/dhcp-4.4.2_p1-r1.ebuild
@@ -271,6 +271,10 @@ pkg_preinst() {
}
pkg_postinst() {
+ if use server ; then
+ tmpfiles_process dhcpd.conf
+ fi
+
if [[ -e "${ROOT}"/etc/init.d/dhcp ]] ; then
ewarn
ewarn "WARNING: The dhcp init script has been renamed to dhcpd"