summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Vinson <nvinson234@gmail.com>2016-04-27 06:46:41 -0700
committerSam Jorna <wraeth@gentoo.org>2016-04-29 17:29:35 +1000
commit5209abd6842cfe1306874c0766f10ec939e4869c (patch)
tree8aef5fbcc676996cfa0a84e718b58179798207cb /net-misc/connman/files
parentdev-python/flask-bootstrap: new package, version 3.3.5.7 (diff)
downloadgentoo-5209abd6842cfe1306874c0766f10ec939e4869c.tar.gz
gentoo-5209abd6842cfe1306874c0766f10ec939e4869c.tar.bz2
gentoo-5209abd6842cfe1306874c0766f10ec939e4869c.zip
net-misc/connman: Version bump to 1.32
Gentoo-bug: 581368 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/connman/files')
-rw-r--r--net-misc/connman/files/connman-1.32-execinfo-assumptions.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch b/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch
new file mode 100644
index 000000000000..eb8e4fc0c131
--- /dev/null
+++ b/net-misc/connman/files/connman-1.32-execinfo-assumptions.patch
@@ -0,0 +1,54 @@
+diff -uNr a/config.h.in b/config.h.in
+--- a/config.h.in 2013-07-02 17:41:03.715261748 +0000
++++ b/config.h.in 2013-07-02 17:41:21.707260667 +0000
+@@ -3,6 +3,9 @@
+ /* Define to 1 if you have the <dlfcn.h> header file. */
+ #undef HAVE_DLFCN_H
+
++/* Define to 1 if you have the <execinfo.h> header file. */
++#undef HAVE_EXECINFO_H
++
+ /* Define to 1 if you have the <inttypes.h> header file. */
+ #undef HAVE_INTTYPES_H
+
+diff -uNr a/configure.ac b/configure.ac
+--- a/configure.ac 2013-07-02 17:41:03.715261748 +0000
++++ b/configure.ac 2013-07-02 17:41:21.719260666 +0000
+@@ -181,6 +181,8 @@
+ AC_CHECK_FUNC(signalfd, dummy=yes,
+ AC_MSG_ERROR(signalfd support is required))
+
++AC_CHECK_HEADERS([execinfo.h], [], [])
++
+ AC_CHECK_LIB(dl, dlopen, dummy=yes,
+ AC_MSG_ERROR(dynamic linking loader is required))
+
+diff -uNr a/src/backtrace.c b/src/backtrace.c
+--- a/src/backtrace.c 2013-07-02 17:41:03.727261747 +0000
++++ b/src/backtrace.c 2013-07-02 17:42:12.717257603 +0000
+@@ -30,7 +30,9 @@
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
++#ifdef HAVE_EXECINFO_H
+ #include <execinfo.h>
++#endif
+ #include <dlfcn.h>
+
+ #include "connman.h"
+@@ -37,6 +38,7 @@
+ void print_backtrace(const char* program_path, const char* program_exec,
+ unsigned int offset)
+ {
++#ifdef HAVE_EXECINFO_H
+ void *frames[99];
+ size_t n_ptrs;
+ unsigned int i;
+@@ -135,6 +138,7 @@
+
+ close(outfd[1]);
+ close(infd[0]);
++#endif
+ }
+
+ static void signal_handler(int signo)