summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2024-10-17 21:52:28 +0200
committerSam James <sam@gentoo.org>2024-10-18 15:35:20 +0100
commita077502da6fe2754c04c4a845fb60d6019d5d684 (patch)
treee5dc2832faa9e6d1400711e8ed14000eca0cfa15 /net-misc/asterisk-g729
parentnet-misc/asterisk-g729: drop 18.0.3.1.9 (diff)
downloadgentoo-a077502da6fe2754c04c4a845fb60d6019d5d684.tar.gz
gentoo-a077502da6fe2754c04c4a845fb60d6019d5d684.tar.bz2
gentoo-a077502da6fe2754c04c4a845fb60d6019d5d684.zip
net-misc/asterisk-g729: add 21.0.3.1.10
Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/asterisk-g729')
-rw-r--r--net-misc/asterisk-g729/Manifest1
-rw-r--r--net-misc/asterisk-g729/asterisk-g729-21.0.3.1.10.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-misc/asterisk-g729/Manifest b/net-misc/asterisk-g729/Manifest
index 16eab3c88181..ecd1c9ded030 100644
--- a/net-misc/asterisk-g729/Manifest
+++ b/net-misc/asterisk-g729/Manifest
@@ -8,3 +8,4 @@ DIST codec_g729a-18.0_3.1.10-x86_32.tar.gz 475393 BLAKE2B ad7b2c7699f82f27bce00a
DIST codec_g729a-18.0_3.1.10-x86_64.tar.gz 476294 BLAKE2B 21fe46bdd544627dbe018730676091f9882ef25a02e6ce436f25757e46b91a6670c410da94c96fb9bc30e5e1976f3803d290049da319a2ad6230612e7805ebc6 SHA512 c7aaa72e7744309971e8abc71da8217ba181f85c163e24ca82bc0ac1276cb4e6e8107edf9f896fee941c8680188f931a14de3d2fbc5cdadfd3c9ecef53c15618
DIST codec_g729a-20.0_3.1.10-x86_32.tar.gz 476843 BLAKE2B 8d014823184f17c158de9720bc903f841f290f1171344bc7a54ad7cf40627b7fcac697e642c35feef4e6eccff58b7fc85775e5d5a31c518b35a3b6c7bf258b19 SHA512 81d7d0921c9f17b31d9d3a3dd7e81844ee17bc9afd58418c2add40409c3eda932330e93411f32b5af67a42877f6abfba5d9b599812cc0655b2cc9851f1257c3c
DIST codec_g729a-20.0_3.1.10-x86_64.tar.gz 476178 BLAKE2B f27787c17929deecf048c0b79f38bd3630375d1e09afe142052ff7b4f9ef3d5577a09b11a11aa551ae6d82f44cf40931550fa5612ec132befa3c9e3776b7dd58 SHA512 91df558f4c88af703bde270d0e360ebba074ab5ff917f163f8a525b7fa0e4a2e7480884effafb1253d6a67a72e640d1cdaba75c10c24283655136d8a356dec56
+DIST codec_g729a-21.0_3.1.10-x86_64.tar.gz 490480 BLAKE2B 71e3d68fdf5180fbef0e1f1f026ef24b91fb876c54bb35706dda4cc243b8a6997ffb16b888cdc2019d996c8192ffc3be8c2cd3f76033017e3c744a61230e3bd9 SHA512 2be1bb6334dbf7c327729cdecb7f303c942a7d02ac5e3180c0234f490ba9e1660c4d9e8ec3033dec9c996ee26dc1bdced39f9d53bc7a4a0dd16c5e9a6e8ff0e0
diff --git a/net-misc/asterisk-g729/asterisk-g729-21.0.3.1.10.ebuild b/net-misc/asterisk-g729/asterisk-g729-21.0.3.1.10.ebuild
new file mode 100644
index 000000000000..f4f58749acc3
--- /dev/null
+++ b/net-misc/asterisk-g729/asterisk-g729-21.0.3.1.10.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="G.729 codec and supporting files for asterisk"
+HOMEPAGE="https://www.sangoma.com/asterisk/software/g729-codec/"
+
+AST_PV="$(ver_cut 1-2)"
+MY_PV="$(ver_rs 2 _)"
+
+# Keep the binary suffix to re-use already downloaded files.
+SRC_URI="https://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-x86_64.tar.gz
+ https://downloads.digium.com/pub/register/x86-64/register -> astregister-x86_64
+ https://downloads.digium.com/pub/register/x86-64/asthostid -> asthostid-x86_64"
+
+S="${WORKDIR}"
+
+LICENSE="Digium"
+SLOT="0/${AST_PV}"
+KEYWORDS="-* ~amd64"
+
+RDEPEND="=net-misc/asterisk-$(ver_cut 1)*"
+
+RESTRICT="mirror strip"
+
+pkg_setup() {
+ QA_FLAGS_IGNORED="/usr/$(get_libdir)/asterisk/modules/codec_g729a.so"
+ QA_PREBUILT="${QA_FLAGS_IGNORED}
+ /usr/sbin/asthostid
+ /usr/sbin/astregister"
+}
+
+src_unpack() {
+ local dfile
+
+ for dfile in ${A}; do
+ [[ "${dfile}" = *.tar.gz ]] && unpack "${dfile}"
+ cp "${DISTDIR}/${dfile}" "${WORKDIR}/" || die "Error copying ${dfile} to ${WORKDIR}"
+ done
+}
+
+src_install() {
+ local binsuffix=x86_64
+
+ newsbin astregister-${binsuffix} astregister
+ newsbin asthostid-${binsuffix} asthostid
+
+ dodoc codec_g729a-${MY_PV}-${binsuffix}/README
+ insinto usr/$(get_libdir)/asterisk/modules/
+ doins "codec_g729a-${MY_PV}-${binsuffix}/codec_g729a.so"
+}
+
+pkg_postinst() {
+ einfo "Please note that Digium's register utility has been installed as astregister"
+}