summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2024-05-10 20:10:21 +0200
committerSam James <sam@gentoo.org>2024-06-02 01:50:36 +0100
commit04fcaab84075e3e7f9477a07784945bf5184c118 (patch)
tree0c25d946e3cd5517fe848131d8882c4d9d7c5711 /net-mail
parentsci-geosciences/gpsd: add missing die, fix indentation (diff)
downloadgentoo-04fcaab84075e3e7f9477a07784945bf5184c118.tar.gz
gentoo-04fcaab84075e3e7f9477a07784945bf5184c118.tar.bz2
gentoo-04fcaab84075e3e7f9477a07784945bf5184c118.zip
net-mail/automx2: upgrade to Python 3.12
- Support Python version 3.12 in ebuild. - Fix documentation URLs. Closes: https://bugs.gentoo.org/929715 Signed-off-by: Ralph Seichter <github@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/36631 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/automx2/automx2-2022.1-r1.ebuild46
-rw-r--r--net-mail/automx2/metadata.xml2
2 files changed, 47 insertions, 1 deletions
diff --git a/net-mail/automx2/automx2-2022.1-r1.ebuild b/net-mail/automx2/automx2-2022.1-r1.ebuild
new file mode 100644
index 000000000000..05f26b65305a
--- /dev/null
+++ b/net-mail/automx2/automx2-2022.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11,12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Email client autoconfiguration service"
+HOMEPAGE="https://rseichter.github.io/automx2/"
+SRC_URI="https://github.com/rseichter/automx2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="acct-user/automx2
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/flask-migrate[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/ldap3[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+python_prepare_all() {
+ sed -i -e "/('scripts'/d" setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x AUTOMX2_CONF="tests/unittest.conf"
+ eunittest tests/
+}
+
+python_install_all() {
+ local DOCS=( "${S}"/docs/*.adoc "${S}"/contrib/*sample.conf )
+ local HTML_DOCS=( "${S}"/docs/*.{html,svg} )
+ newconfd "${FILESDIR}/confd" "${PN}"
+ newinitd "${FILESDIR}/init-r1" "${PN}"
+ insinto /etc
+ newins "${FILESDIR}/conf" "${PN}.conf"
+ distutils-r1_python_install_all
+}
diff --git a/net-mail/automx2/metadata.xml b/net-mail/automx2/metadata.xml
index 54630a522f9b..01690ef05208 100644
--- a/net-mail/automx2/metadata.xml
+++ b/net-mail/automx2/metadata.xml
@@ -10,7 +10,7 @@
(autoconfig) in one tool.
</longdescription>
<upstream>
- <doc>https://github.com/rseichter/automx2/blob/master/doc/automx2.pdf</doc>
+ <doc>https://rseichter.github.io/automx2/</doc>
<maintainer>
<email>automx2@seichter.de</email>
<name>Ralph Seichter</name>