summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Linden <karl.j.linden@gmail.com>2017-09-04 20:45:35 +0200
committerDavid Seifert <soap@gentoo.org>2017-09-05 10:04:30 +0200
commit58d30be41daa34f565ab38ab7d92c64fe92acf5d (patch)
treea6a5c9b22f066404b987976636d5a24e47c6bf3f /net-libs
parentsys-process/vixie-cron: Fix SELinux support (diff)
downloadgentoo-58d30be41daa34f565ab38ab7d92c64fe92acf5d.tar.gz
gentoo-58d30be41daa34f565ab38ab7d92c64fe92acf5d.tar.bz2
gentoo-58d30be41daa34f565ab38ab7d92c64fe92acf5d.zip
net-libs/libtorrent-rasterbar: fix compilation with boost-1.65.0
* Apply upstream patch from commit 7eb3cf5. Closes: https://bugs.gentoo.org/show_bug.cgi?id=629802 Package-Manager: Portage-2.3.8, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/5615
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-1.0.11-boost-config-header.patch31
-rw-r--r--net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.11-r1.ebuild117
2 files changed, 148 insertions, 0 deletions
diff --git a/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-1.0.11-boost-config-header.patch b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-1.0.11-boost-config-header.patch
new file mode 100644
index 000000000000..f3a81c381d81
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/files/libtorrent-rasterbar-1.0.11-boost-config-header.patch
@@ -0,0 +1,31 @@
+commit 7eb3cf6bc6dbada3fa7bb7ff4d5981182813a0e2
+Author: arvidn <arvid@cs.umu.se>
+Date: Tue Jul 11 23:16:50 2017 -0700
+
+ use the official boost.config header
+
+diff --git a/include/libtorrent/export.hpp b/include/libtorrent/export.hpp
+index 87536af2a..503afe27a 100644
+--- a/include/libtorrent/export.hpp
++++ b/include/libtorrent/export.hpp
+@@ -33,19 +33,7 @@ POSSIBILITY OF SUCH DAMAGE.
+ #ifndef TORRENT_EXPORT_HPP_INCLUDED
+ #define TORRENT_EXPORT_HPP_INCLUDED
+
+-#if !defined(BOOST_COMPILER_CONFIG) && !defined(BOOST_NO_COMPILER_CONFIG)
+-# include <boost/config/select_compiler_config.hpp>
+-#endif
+-#ifdef BOOST_COMPILER_CONFIG
+-# include BOOST_COMPILER_CONFIG
+-#endif
+-
+-#if !defined(BOOST_PLATFORM_CONFIG) && !defined(BOOST_NO_PLATFORM_CONFIG)
+-# include <boost/config/select_platform_config.hpp>
+-#endif
+-#ifdef BOOST_PLATFORM_CONFIG
+-# include BOOST_PLATFORM_CONFIG
+-#endif
++#include <boost/config.hpp>
+
+ // backwards compatibility with older versions of boost
+ #if !defined BOOST_SYMBOL_EXPORT && !defined BOOST_SYMBOL_IMPORT
diff --git a/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.11-r1.ebuild b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.11-r1.ebuild
new file mode 100644
index 000000000000..2bdd886902f5
--- /dev/null
+++ b/net-libs/libtorrent-rasterbar/libtorrent-rasterbar-1.0.11-r1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads"
+DISTUTILS_OPTIONAL=true
+DISTUTILS_IN_SOURCE_BUILD=true
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_all_version_separators _)
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://libtorrent.org"
+SRC_URI="https://github.com/arvidn/libtorrent/releases/download/libtorrent-${MY_PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/8"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +dht doc examples +geoip libressl python +ssl static-libs test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+COMMON_DEPEND="
+ dev-libs/boost:=[threads]
+ virtual/libiconv
+ geoip? ( dev-libs/geoip )
+ python? (
+ ${PYTHON_DEPS}
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/libtool
+"
+RDEPEND="${COMMON_DEPEND}
+ examples? ( !net-p2p/mldonkey )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.9-test_torrent_parse.patch"
+ # RC_1_0 branch
+ "${FILESDIR}/${P}-fix-abicompat.patch"
+ "${FILESDIR}/${P}-move-header.patch"
+ # master branch
+ "${FILESDIR}/${P}-fix-test_ssl.patch"
+ "${FILESDIR}/${P}-boost-config-header.patch"
+)
+
+src_prepare() {
+ default
+
+ # bug 578026
+ # prepend -L${S}/... to ensure bindings link against the lib we just built
+ sed -i -e "s|^|-L${S}/src/.libs |" bindings/python/compile_flags.in || die
+
+ use python && distutils-r1_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable debug logging)
+ $(use_enable debug statistics)
+ $(use_enable debug disk-stats)
+ $(use_enable dht dht $(usex debug logging yes))
+ $(use_enable examples)
+ $(use_enable geoip)
+ $(use_with geoip libgeoip)
+ $(use_enable ssl encryption)
+ $(use_enable static-libs static)
+ $(use_enable test tests)
+ --with-libiconv
+ )
+ econf "${myeconfargs[@]}"
+
+ if use python; then
+ myeconfargs+=(
+ --enable-python-binding
+ --with-boost-python
+ )
+ python_configure() {
+ econf "${myeconfargs[@]}"
+ }
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ default
+
+ python_compile() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_compile
+ }
+ use python && distutils-r1_src_compile
+}
+
+src_install() {
+ use doc && HTML_DOCS+=( "${S}"/docs )
+
+ default
+
+ python_install() {
+ cd "${BUILD_DIR}/../bindings/python" || die
+ distutils-r1_python_install
+ }
+ use python && distutils-r1_src_install
+
+ find "${D}" -name '*.la' -delete || die
+}