summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2022-12-27 03:26:07 +0300
committerSam James <sam@gentoo.org>2022-12-27 10:22:17 +0000
commit14545c056ef18019e9de4cfb41ec1d8da538a8c8 (patch)
tree2101900774b29f36b21e979d7b61c9638d26e809 /net-libs
parentdev-util/lttng-tools: add 2.13.8 (diff)
downloadgentoo-14545c056ef18019e9de4cfb41ec1d8da538a8c8.tar.gz
gentoo-14545c056ef18019e9de4cfb41ec1d8da538a8c8.tar.bz2
gentoo-14545c056ef18019e9de4cfb41ec1d8da538a8c8.zip
net-libs/libvncserver: version bump to 0.9.14
Bug: https://bugs.gentoo.org/887067 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/28833 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libvncserver/Manifest1
-rw-r--r--net-libs/libvncserver/libvncserver-0.9.14.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-libs/libvncserver/Manifest b/net-libs/libvncserver/Manifest
index c7569e5d4778..560434399356 100644
--- a/net-libs/libvncserver/Manifest
+++ b/net-libs/libvncserver/Manifest
@@ -1 +1,2 @@
DIST LibVNCServer-0.9.13.tar.gz 567491 BLAKE2B 138c7ca63f8cd30a21dc1b58aafa744e12a1a9eca503ffec18a63d18791d7a5df4eef176d7e4e797a2aadda1dd04d1b051abfd76bf5c6806d558c09ffee78cce SHA512 18b0a1698d32bbdbfe6f65f76130b2a95860e3cc76e8adb904269663698c7c0ae982f451fda1f25e5461f096045d40a89d9014258f439366d5b4feaa4999d643
+DIST LibVNCServer-0.9.14.tar.gz 593516 BLAKE2B 6585e15e2ade08211ace0ae40deb07eca04b96dcfe38fb4d2e7d7a7192ca22dda546cb69fc4be6c6b7eb83c8afb0ea14d7cee3779a9e64c138ec861efeb540b8 SHA512 8a0a58e355154cbe1e5807864dc874b063c5e5f5e20d64ae541d49d51b654a35ca9c625adc5c303b6570fa79c19f82d87a37612f9801b453ccf862bd77c06fcc
diff --git a/net-libs/libvncserver/libvncserver-0.9.14.ebuild b/net-libs/libvncserver/libvncserver-0.9.14.ebuild
new file mode 100644
index 000000000000..21cab9d4d577
--- /dev/null
+++ b/net-libs/libvncserver/libvncserver-0.9.14.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+MY_P="LibVNCServer-${PV}"
+
+DESCRIPTION="library for creating vnc servers"
+HOMEPAGE="https://libvnc.github.io/"
+SRC_URI="https://github.com/LibVNC/${PN}/archive/${MY_P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_P}"
+
+# common/d3des.*: https://github.com/LibVNC/libvncserver/issues/88
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+ BSD MIT"
+# no sub slot wanted (yet), see #578958
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+24bpp +filetransfer gcrypt gnutls ipv6 +jpeg lzo +png sasl ssl systemd +threads +zlib"
+# https://bugs.gentoo.org/690202
+# https://bugs.gentoo.org/435326
+# https://bugs.gentoo.org/550916
+REQUIRED_USE="
+ filetransfer? ( threads )
+ jpeg? ( zlib )
+ png? ( zlib )
+ ssl? ( !gnutls? ( threads ) )
+"
+
+DEPEND="
+ gcrypt? ( >=dev-libs/libgcrypt-1.5.3:0= )
+ ssl? (
+ !gnutls? (
+ >=dev-libs/openssl-1.0.2:0=
+ )
+ gnutls? ( >=net-libs/gnutls-2.12.23-r6:0= )
+ )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ lzo? ( dev-libs/lzo )
+ png? ( >=media-libs/libpng-1.6.10:0= )
+ sasl? ( dev-libs/cyrus-sasl )
+ systemd? ( sys-apps/systemd:= )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1:0= )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS.md README.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DWITH_EXAMPLES=OFF
+ -DWITH_FFMPEG=OFF
+ -DWITH_GTK=OFF
+ -DWITH_SDL=OFF
+ -DWITH_24BPP=$(usex 24bpp ON OFF)
+ -DWITH_TIGHTVNC_FILETRANSFER=$(usex filetransfer ON OFF)
+ -DWITH_GCRYPT=$(usex gcrypt ON OFF)
+ -DWITH_GNUTLS=$(usex gnutls $(usex ssl ON OFF) OFF)
+ -DWITH_IPv6=$(usex ipv6 ON OFF)
+ -DWITH_JPEG=$(usex jpeg ON OFF)
+ -DWITH_LZO=$(usex lzo ON OFF)
+ -DWITH_OPENSSL=$(usex gnutls OFF $(usex ssl ON OFF))
+ -DWITH_PNG=$(usex png ON OFF)
+ -DWITH_SASL=$(usex sasl ON OFF)
+ -DWITH_SYSTEMD=$(usex systemd ON OFF)
+ -DWITH_THREADS=$(usex threads ON OFF)
+ -DWITH_ZLIB=$(usex zlib ON OFF)
+ )
+ cmake_src_configure
+}