summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-23 00:43:24 +0100
committerSam James <sam@gentoo.org>2024-06-23 01:27:05 +0100
commit2485f899d21133d9f2b4475c693ae82d44ca549b (patch)
treece448e1d79dcc32a6ad95f6603b4be80a2c51d21 /net-libs/wandio
parentnet-libs/libtrace: drop 4.0.18_p1, 4.0.19_p1, 4.0.20 (diff)
downloadgentoo-2485f899d21133d9f2b4475c693ae82d44ca549b.tar.gz
gentoo-2485f899d21133d9f2b4475c693ae82d44ca549b.tar.bz2
gentoo-2485f899d21133d9f2b4475c693ae82d44ca549b.zip
net-libs/wandio: add 4.2.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/wandio')
-rw-r--r--net-libs/wandio/Manifest1
-rw-r--r--net-libs/wandio/wandio-4.2.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-libs/wandio/Manifest b/net-libs/wandio/Manifest
index 0a339c4ac462..5c4794091890 100644
--- a/net-libs/wandio/Manifest
+++ b/net-libs/wandio/Manifest
@@ -1,2 +1,3 @@
DIST wandio-4.2.3_p1.tar.gz 15418423 BLAKE2B 1274f10b87964e2dc87ed25a465991b1e4e9211b75fb5ac5a13a0aa535ff30ddfa69059b3d41de7dc758220bda8dd9d02ca7ed31b7c0ca2997641968cc729e48 SHA512 b4bfff9d33010c04826318c560592ee7f7aba9fccd0eba0f29c6294a636971bf4ac5105ffb9addfc22946e7b7234396dafa6c7e0a0d8de3ee1b7e586c069b438
DIST wandio-4.2.4.tar.gz 15417703 BLAKE2B a4b6f066ac513975c669bd8f57b8791b87a240e6b5a6ad55340a829adfe89b614ab3541cab224e7cc4fb5daf0656108d02de231bce5cb2f1660871d1b3f9c13e SHA512 ac267d8762b38c073a67e7c6b3e7efbd551b668b5b56879c15aefa4ea353b5d86cea0f30acde76be187243843bdb08cae101dea0f346244b07a43a2796a6ca62
+DIST wandio-4.2.6.tar.gz 17183116 BLAKE2B 0097510e5b7a3f8567d687db79185b190c963754b1a856809d37b2665087867f017a3f1d2c03ed404a5471c4680d8e5030458200d908878bcad9d3fd1d902804 SHA512 931bdfe91c8923de52217873d5a12568bcac97b2ab7e4e50f48cd9999d7b3887175885c3f56250b0cd822584bbf4a9262b017ab57ed599ddd288abda1fad9885
diff --git a/net-libs/wandio/wandio-4.2.6.ebuild b/net-libs/wandio/wandio-4.2.6.ebuild
new file mode 100644
index 000000000000..dd14502b7512
--- /dev/null
+++ b/net-libs/wandio/wandio-4.2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C library for simple and efficient file IO"
+HOMEPAGE="https://github.com/LibtraceTeam/wandio"
+SRC_URI="https://github.com/LibtraceTeam/wandio/archive/refs/tags/${PV}-1.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}-1
+
+LICENSE="LGPL-3"
+SLOT="0/6"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo lz4 test zlib zstd"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( bzip2 lzma lzo lz4 zlib zstd )"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
+ lz4? ( app-arch/lz4:= )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+ zstd? ( app-arch/zstd:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( app-arch/lzop )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with lz4) \
+ $(use_with zlib) \
+ $(use_with zstd)
+}
+
+src_test() {
+ pushd test || die
+
+ "${BROOT}"/bin/bash do-basic-tests.sh || die
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}