summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:33:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:36:40 +0200
commitff65bc41d94a8b559912333a95ac6252dc0fd1b1 (patch)
tree16bc13b4ca790ddc67f7df698af1b52ca82528c6 /net-libs/telepathy-qt
parentnet-libs/libsignon-glib: Support python3_11, EAPI-8 (diff)
downloadgentoo-ff65bc41d94a8b559912333a95ac6252dc0fd1b1.tar.gz
gentoo-ff65bc41d94a8b559912333a95ac6252dc0fd1b1.tar.bz2
gentoo-ff65bc41d94a8b559912333a95ac6252dc0fd1b1.zip
net-libs/telepathy-qt: update EAPI 7 -> 8, enable py3.11
Update EGIT_REPO_URI, HOMEPAGE. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild27
1 files changed, 13 insertions, 14 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
index 806f66f84703..e61c8d77eecc 100644
--- a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="xml(+)"
if [[ ${PV} == *9999* ]]; then
- EGIT_REPO_URI=( "https://gitlab.freedesktop.org/telepathy/${PN}" )
+ EGIT_REPO_URI=( "https://github.com/TelepathyIM/${PN}" )
inherit git-r3
else
SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
@@ -16,25 +16,15 @@ fi
inherit python-any-r1 cmake virtualx
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
-HOMEPAGE="https://telepathy.freedesktop.org/"
+HOMEPAGE="https://telepathy.freedesktop.org/ https://github.com/TelepathyIM/telepathy-qt/"
LICENSE="LGPL-2.1"
SLOT="0"
IUSE="debug farstream test"
REQUIRED_USE="test? ( farstream )"
-
RESTRICT="!test? ( test )"
-BDEPEND="${PYTHON_DEPS}
- virtual/pkgconfig
- test? (
- dev-libs/glib:2
- $(python_gen_any_dep '
- dev-python/dbus-python[${PYTHON_USEDEP}]
- ')
- )
-"
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdbus:5
@@ -52,6 +42,15 @@ DEPEND="${RDEPEND}
dev-qt/qttest:5
)
"
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+ test? (
+ dev-libs/glib:2
+ $(python_gen_any_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ ')
+ )
+"
python_check_deps() {
use test || return 0