summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-08-11 11:20:46 +0100
committerSam James <sam@gentoo.org>2022-08-11 11:20:51 +0100
commit185ddb8455b25bcfa77d52513e1d5f03652053e3 (patch)
tree7837320feea814656fec94d8bdf4857380ed9c50 /net-libs/telepathy-qt
parentkde-frameworks/extra-cmake-modules: fix PythonAnyMismatchedDepHasVersionCheck (diff)
downloadgentoo-185ddb8455b25bcfa77d52513e1d5f03652053e3.tar.gz
gentoo-185ddb8455b25bcfa77d52513e1d5f03652053e3.tar.bz2
gentoo-185ddb8455b25bcfa77d52513e1d5f03652053e3.zip
net-libs/telepathy-qt: fix PythonAnyMismatchedDepHasVersionCheck
has_version was checking DEPEND, not BDEPEND, so change to python_has_version for better defaults (defaults to BDEPEND) but also nicer output. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-libs/telepathy-qt')
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild4
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
index 9f392ed86abb..af50e027063c 100644
--- a/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -49,7 +49,7 @@ BDEPEND="${PYTHON_DEPS}
python_check_deps() {
use test || return 0
- has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
}
pkg_setup() {
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
index 4ae1fc73d370..806f66f84703 100644
--- a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -55,7 +55,7 @@ DEPEND="${RDEPEND}
python_check_deps() {
use test || return 0
- has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
+ python_has_version "dev-python/dbus-python[${PYTHON_USEDEP}]"
}
pkg_setup() {