summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/obby
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/obby')
-rw-r--r--net-libs/obby/Manifest1
-rw-r--r--net-libs/obby/metadata.xml13
-rw-r--r--net-libs/obby/obby-0.4.8.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/net-libs/obby/Manifest b/net-libs/obby/Manifest
new file mode 100644
index 000000000000..d9bcfa950d7b
--- /dev/null
+++ b/net-libs/obby/Manifest
@@ -0,0 +1 @@
+DIST obby-0.4.8.tar.gz 530525 SHA256 7d1d7ba6e800cea1b1a3c47d1189f959ef49a647ebe77170351e2dfd27b89b67 SHA512 39cd01e74f8df805bd6f077afab023f70f6da16d421dd0d12abc82972a9ec3e2563cc4ef6bf99c74b59f1c96e18eb3d5065f8b07add8ecb56c26601715f184d0 WHIRLPOOL bf00c4f68e64e2cf1fb39031f4f0ede396c9842aaecf94dcaed6d8f092fb35194e66475406963b510c66e0814706ceb710dd0a183ba876fe5c3109f1e685ea44
diff --git a/net-libs/obby/metadata.xml b/net-libs/obby/metadata.xml
new file mode 100644
index 000000000000..47040ec30053
--- /dev/null
+++ b/net-libs/obby/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+ <maintainer>
+ <email>xarthisius@gentoo.org</email>
+ <name>Kacper Kowalik</name>
+ </maintainer>
+ <longdescription>Framework to synchronize changes within a text documents to other participants of a session</longdescription>
+</pkgmetadata>
diff --git a/net-libs/obby/obby-0.4.8.ebuild b/net-libs/obby/obby-0.4.8.ebuild
new file mode 100644
index 000000000000..d0b7c2c74f83
--- /dev/null
+++ b/net-libs/obby/obby-0.4.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit multilib
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://gobby.0x539.de/"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc x86"
+IUSE="avahi ipv6 nls static-libs"
+
+RDEPEND="net-libs/net6
+ dev-libs/libsigc++:2
+ avahi? ( net-dns/avahi[dbus] )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ econf \
+ $(use_with avahi zeroconf) \
+ $(use_enable ipv6) \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib${PN}.la
+}