summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2023-03-30 09:55:09 -0400
committerCraig Andrews <candrews@gentoo.org>2023-03-30 09:55:31 -0400
commit6962ee6641e899810f8e21c54770ab7997387f8b (patch)
tree249947b1c63f176a2fab319f4dedf69a93decf85 /net-libs/ngtcp2
parentprofiles: Mask libgfbgraph, libzapojit, and gnome-online-miners for removal (diff)
downloadgentoo-6962ee6641e899810f8e21c54770ab7997387f8b.tar.gz
gentoo-6962ee6641e899810f8e21c54770ab7997387f8b.tar.bz2
gentoo-6962ee6641e899810f8e21c54770ab7997387f8b.zip
net-libs/ngtcp2: add 0.14.1
Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'net-libs/ngtcp2')
-rw-r--r--net-libs/ngtcp2/Manifest1
-rw-r--r--net-libs/ngtcp2/ngtcp2-0.14.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/net-libs/ngtcp2/Manifest b/net-libs/ngtcp2/Manifest
index a0ec37b5f177..15f5e1206b74 100644
--- a/net-libs/ngtcp2/Manifest
+++ b/net-libs/ngtcp2/Manifest
@@ -1 +1,2 @@
DIST ngtcp2-0.14.0.tar.xz 592228 BLAKE2B 245390baca48948a438edede40a00f8a65d9dfb2d674711c8c12c3cdea229b8740d565581941a4973535fa290a84343205fa5ec8dfde479a1795613127a83304 SHA512 6401302bcec57271e93405fb66ad6695b53645866c63f7d766c1b98dbc7ac1c884490b436c3dc71bf0541733e7a7b29e6bb90ed659290549a4abe50b299da231
+DIST ngtcp2-0.14.1.tar.xz 585788 BLAKE2B 68574767c701432e7558fa85cbad0d49934d220e292ceb82cdf19a715f247c6ec9b3a2b87def1176ade067a78c84bd3495936847a9a53fcadaff7b66971eca8d SHA512 52c55bc322d979d020ab3124a7cc0033d0f3e5649e3c8ee5f00aa64dbad83c4f199d50685704cc9372821e7fc81c59eea79f33894260b5dca171712d5b3899a0
diff --git a/net-libs/ngtcp2/ngtcp2-0.14.1.ebuild b/net-libs/ngtcp2/ngtcp2-0.14.1.ebuild
new file mode 100644
index 000000000000..4d3a4cbaa377
--- /dev/null
+++ b/net-libs/ngtcp2/ngtcp2-0.14.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/ngtcp2/ngtcp2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ngtcp2/ngtcp2/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~hppa ~riscv ~x86"
+fi
+
+DESCRIPTION="Implementation of the IETF QUIC Protocol"
+HOMEPAGE="https://github.com/ngtcp2/ngtcp2/"
+
+LICENSE="MIT"
+SLOT="0/0"
+IUSE="+gnutls openssl +ssl static-libs test"
+REQUIRED_USE="ssl? ( || ( gnutls openssl ) )"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ ssl? (
+ gnutls? ( >=net-libs/gnutls-3.7.2:0= )
+ openssl? (
+ >=dev-libs/openssl-1.1.1:0=
+ )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/cunit-2.1[${MULTILIB_USEDEP}] )"
+RESTRICT="!test? ( test )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DENABLE_STATIC_LIB=$(usex static-libs)
+ -DENABLE_GNUTLS=$(usex gnutls)
+ -DENABLE_OPENSSL=$(usex openssl)
+ -DENABLE_BORINGSSL=OFF
+ -DENABLE_PICOTLS=OFF
+ -DENABLE_WOLFSSL=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libnghttp3=ON
+ )
+ cmake_src_configure
+}
+
+multilib_src_test() {
+ cmake_build check
+}