summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-libs/libnipper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-libs/libnipper')
-rw-r--r--net-libs/libnipper/Manifest1
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch16
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch13
-rw-r--r--net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch13
-rw-r--r--net-libs/libnipper/libnipper-0.12.6-r1.ebuild23
-rw-r--r--net-libs/libnipper/metadata.xml12
6 files changed, 78 insertions, 0 deletions
diff --git a/net-libs/libnipper/Manifest b/net-libs/libnipper/Manifest
new file mode 100644
index 000000000000..460c95ba2f04
--- /dev/null
+++ b/net-libs/libnipper/Manifest
@@ -0,0 +1 @@
+DIST libnipper-0.12.6.tgz 444578 SHA256 70cd0cb66d8c0718c7d1ec9bc510d70ed17efed0213833790e79d7ca43fccf8c SHA512 eb6eabce06a71463f8dad59a2aca13583e9ae8113b6997a7946b9bbafe54cd0668189c915f917ffcb7ffe3b5dc6dbbf7d37874ec226e5bd8cdd3c8999f9e10b0 WHIRLPOOL dae559647ec689087d103fb0a8da4ef5179afc6a426412ab211eff6009df87b264decfe19aca84f29e3eaa187b26dc558341670c4efd3b8e47a3c201668ba1f9
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch b/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch
new file mode 100644
index 000000000000..45b65b5e0383
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-gcc47.patch
@@ -0,0 +1,16 @@
+ https://bugs.gentoo.org/423813
+
+
+ device/device.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+--- a/device/device.cpp
++++ b/device/device.cpp
+@@ -31,6 +31,7 @@
+
+
+ // Includes...
++#include <unistd.h>
+ #include "../globaldefs.h"
+ #include "errortext.h"
+ #include "device.h"
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch b/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch
new file mode 100644
index 000000000000..332276e14329
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-glibc-2.10.patch
@@ -0,0 +1,13 @@
+diff --git a/device/common/misc.cpp b/device/common/misc.cpp
+index 7b3a7fb..612aacd 100644
+--- a/device/common/misc.cpp
++++ b/device/common/misc.cpp
+@@ -198,7 +198,7 @@ const char *Device::cidrToNetmask(const char *cidr)
+ unsigned int Device::ipAddressToNum(const char *address)
+ {
+ // Variables...
+- char *addressPointer = 0;
++ const char *addressPointer = 0;
+ unsigned int returnAddress = 0;
+ int tempInt = 0;
+
diff --git a/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch b/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch
new file mode 100644
index 000000000000..471236b84f92
--- /dev/null
+++ b/net-libs/libnipper/files/libnipper-0.12.6-multilib-strict.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4cc6260..d4518fb 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -319,7 +319,7 @@ SET(libnipper_SRC
+ ADD_LIBRARY(nipper SHARED ${libnipper_SRC})
+
+ # Install...
+-INSTALL(TARGETS nipper LIBRARY DESTINATION /usr/lib)
++INSTALL(TARGETS nipper LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR})
+ INSTALL(FILES nipper.conf DESTINATION /etc)
+ INSTALL(FILES libnipper.h config.h DESTINATION /usr/include/libnipper/)
+ INSTALL(FILES man/nipper.conf.5 DESTINATION /usr/share/man/man5)
diff --git a/net-libs/libnipper/libnipper-0.12.6-r1.ebuild b/net-libs/libnipper/libnipper-0.12.6-r1.ebuild
new file mode 100644
index 000000000000..78b1ff34a064
--- /dev/null
+++ b/net-libs/libnipper/libnipper-0.12.6-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit base cmake-utils
+
+DESCRIPTION="A router configuration security analysis library"
+HOMEPAGE="http://nipper.titania.co.uk/"
+SRC_URI="mirror://sourceforge/nipper/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${P}-glibc-2.10.patch"
+ "${FILESDIR}/${P}-gcc47.patch"
+ "${FILESDIR}/${P}-multilib-strict.patch"
+)
diff --git a/net-libs/libnipper/metadata.xml b/net-libs/libnipper/metadata.xml
new file mode 100644
index 000000000000..34e2b197ce46
--- /dev/null
+++ b/net-libs/libnipper/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ikelos@gentoo.org</email>
+ <name>Mike Auty</name>
+ </maintainer>
+ <longdescription>A library for conducting security audits of cisco and other firewall device configurations.</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">nipper</remote-id>
+ </upstream>
+</pkgmetadata>