summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiuseppe Foti <foti.giuseppe@gmail.com>2023-09-25 12:27:27 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-09-27 08:58:18 +0200
commit716d8567b8534cea0085bcead0af0d0f8833ba52 (patch)
tree8f90aafcb8ace389c5ae28e691cf4fb702abc0f3 /net-analyzer
parentgnome-base/gnome-flashback: add myself as a maintainer (diff)
downloadgentoo-716d8567b8534cea0085bcead0af0d0f8833ba52.tar.gz
gentoo-716d8567b8534cea0085bcead0af0d0f8833ba52.tar.bz2
gentoo-716d8567b8534cea0085bcead0af0d0f8833ba52.zip
net-analyzer/gsa: add 22.7.0
Signed-off-by: Giuseppe Foti <foti.giuseppe@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/33049 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/gsa/Manifest2
-rw-r--r--net-analyzer/gsa/gsa-22.7.0.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/net-analyzer/gsa/Manifest b/net-analyzer/gsa/Manifest
index 3ed9ca3cea4c..7291a9f7b164 100644
--- a/net-analyzer/gsa/Manifest
+++ b/net-analyzer/gsa/Manifest
@@ -4,3 +4,5 @@ DIST gsa-22.5.0-node_modules.tar.xz 26394052 BLAKE2B 77e74ccacecd681e846884af463
DIST gsa-22.5.0.tar.gz 3586703 BLAKE2B 33d9f5e32ccc33e4c1d24665bd7ba0819dc22281772c7ebba24d8c82f93bcc21e8b90f3e0666b9ed8846e2a88417f8bf5999619577c15c307485a7ce3243d104 SHA512 2f119f3d8b213cb10abc7b2a25052e943518f8a2c5950f6eb6e5227bf30f7467ddbcf78bbed5f499b96a0bb517c5033f38477f332a14f449b7b04e7b7902843b
DIST gsa-22.5.3-node_modules.tar.xz 23161212 BLAKE2B 4bd48e37034cbe8b142392247f7c3231d97bea3d2327833f5d9fbe6b964b5a8f0f61a7d8db0750291fd750fb24bf401e0a6691123e876d76da68810662779df6 SHA512 2863e937bdfad8207a57d03d67f0fb573435845823ce2533fab4002ac25e37903ab21d6e53f272d39bfb900d4793c907d33d56dfe1b88469ad5a4ffcd3201613
DIST gsa-22.5.3.tar.gz 3620562 BLAKE2B 1b2104bea4d5cb39d9faab05e0e6b1ac0b15c6d342f2066808b3b00fb9e4a07efd8d792eeb2ec1507172e3188770ba428ff5d2a913d00db40d28f899bea23d9f SHA512 fb7ee8b65cfac67789fe392c5734ef2267f80a9f6ac42272e02f21b266f7933c06d5aef33bfa1bedf2782016e26ca849a764f7150ecc8cc6fa8d206c6dd1ae71
+DIST gsa-22.7.0.tar.gz 3593214 BLAKE2B 9a9b4969735c8c05c67f490c98a008816ad6602c6a7a7cceaa611783087da63bde5fbeebe42f171e917820f5c7a79b1a486b41f0c945749c737aa3f4f47ec94c SHA512 e9832666c6218b5d8af9e7af5e088f3dc1e12eac0cbc06c1ccaf268e34a377a5892761dc6a41278c5342a30b008a58c10a36a5b10ee955a77bd55d9dfecfbd44
+DIST gsa-node-modules-22.7.0.tar.xz 27964004 BLAKE2B cbc7120763124deb79ddbcb12037ad8a031ef4de972086866a8393fef39c109a30e90d5f6d7948a55aca518c1ebc3ae46c12ad5440bc89002254bec64f5253e7 SHA512 594f0ffce70514bae8334d749f4e690cdb040b81c8a91238e5bbac18088a0866fe8a78be8a323b813cb5c751e69419c80da611ba7f619797dd9b502c320529b4
diff --git a/net-analyzer/gsa/gsa-22.7.0.ebuild b/net-analyzer/gsa/gsa-22.7.0.ebuild
new file mode 100644
index 000000000000..a45132ee3340
--- /dev/null
+++ b/net-analyzer/gsa/gsa-22.7.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_NODE_N="node-modules"
+MY_NODE_D="node_modules"
+MY_NODE_PV="${PV}"
+
+DESCRIPTION="Greenbone Security Assistant"
+HOMEPAGE="https://www.greenbone.net https://github.com/greenbone/gsa"
+SRC_URI="
+ https://github.com/greenbone/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/greenbone/${PN}/releases/download/v${PV}/${PN}-${MY_NODE_N}-${PV}.tar.xz
+"
+
+SLOT="0"
+LICENSE="AGPL-3+"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ >=net-libs/nodejs-14.0.0[ssl]
+ >=sys-apps/yarn-1.15.2
+"
+
+MY_NODE_DIR="${S}/${MY_NODE_D}/"
+
+src_prepare() {
+ default
+ # We will use pre-generated npm stuff.
+ mv "${WORKDIR}/${MY_NODE_D}" "${MY_NODE_DIR}" || die "couldn't move node_modules"
+
+ # Make SVGR not traverse the path up to / looking for a
+ # configuration file. Fixes
+ # Error: EACCES: permission denied, open '/.config/svgrrc'
+ # in case a directory /.config exists, see https://bugs.gentoo.org/909731
+ echo "runtimeConfig: false" > .svgrrc.yml || die
+}
+
+src_compile() {
+ # setting correct PATH for finding react-js
+ NODE_ENV=production PATH="${PATH}:${MY_NODE_DIR}/.bin/" \
+ yarn --offline build || die
+}
+
+src_install() {
+ insinto "usr/share/gvm/gsad/web"
+ doins -r build/*
+}