summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-30 23:56:00 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:57 +0100
commit445978620088aee745651f519fcc50cae644d367 (patch)
tree4ef1733f10dafb740e60b4f2c73aaddda5484717 /net-analyzer/suricata
parentnet-analyzer/smokeping: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-445978620088aee745651f519fcc50cae644d367.tar.gz
gentoo-445978620088aee745651f519fcc50cae644d367.tar.bz2
gentoo-445978620088aee745651f519fcc50cae644d367.zip
net-analyzer/suricata: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/suricata')
-rw-r--r--net-analyzer/suricata/suricata-5.0.7.ebuild2
-rw-r--r--net-analyzer/suricata/suricata-6.0.3.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/net-analyzer/suricata/suricata-5.0.7.ebuild b/net-analyzer/suricata/suricata-5.0.7.ebuild
index 50b8ba84db3c..b2e2f7e436d8 100644
--- a/net-analyzer/suricata/suricata-5.0.7.ebuild
+++ b/net-analyzer/suricata/suricata-5.0.7.ebuild
@@ -147,6 +147,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
elog
if use systemd; then
elog "Suricata requires either the mode of operation (e.g. --af-packet) or the interface to listen on (e.g. -i eth0)"
diff --git a/net-analyzer/suricata/suricata-6.0.3.ebuild b/net-analyzer/suricata/suricata-6.0.3.ebuild
index c6dfbc4f14b8..6b5b71ffe43b 100644
--- a/net-analyzer/suricata/suricata-6.0.3.ebuild
+++ b/net-analyzer/suricata/suricata-6.0.3.ebuild
@@ -147,6 +147,8 @@ src_install() {
}
pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
elog
if use systemd; then
elog "Suricata requires either the mode of operation (e.g. --af-packet) or the interface to listen on (e.g. -i eth0)"