summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-10-05 19:50:50 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-10-05 20:33:31 -0400
commit6794a88c44a772e273d081b4b5d6212aaef81d1e (patch)
treea80159b6dce90ba7764c5da18f5d93a7d6b9e5ab /net-analyzer/pinger
parentwww-apache/mod_auth_xradius: fix build with upcoming clang16 (diff)
downloadgentoo-6794a88c44a772e273d081b4b5d6212aaef81d1e.tar.gz
gentoo-6794a88c44a772e273d081b4b5d6212aaef81d1e.tar.bz2
gentoo-6794a88c44a772e273d081b4b5d6212aaef81d1e.zip
net-analyzer/pinger: fix build with upcoming clang16
Closes: https://bugs.gentoo.org/870871 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'net-analyzer/pinger')
-rw-r--r--net-analyzer/pinger/files/pinger-0.33-clang16.patch8
-rw-r--r--net-analyzer/pinger/pinger-0.33-r1.ebuild3
2 files changed, 10 insertions, 1 deletions
diff --git a/net-analyzer/pinger/files/pinger-0.33-clang16.patch b/net-analyzer/pinger/files/pinger-0.33-clang16.patch
new file mode 100644
index 000000000000..1a6fe6cf03da
--- /dev/null
+++ b/net-analyzer/pinger/files/pinger-0.33-clang16.patch
@@ -0,0 +1,8 @@
+https://bugs.gentoo.org/870871
+--- a/src/interface_ncurses.c
++++ b/src/interface_ncurses.c
+@@ -41,3 +41,3 @@
+ * characters */
+-static nr_print_ull(char *c, int max_chars, unsigned long long l)
++static int nr_print_ull(char *c, int max_chars, unsigned long long l)
+ {
diff --git a/net-analyzer/pinger/pinger-0.33-r1.ebuild b/net-analyzer/pinger/pinger-0.33-r1.ebuild
index 32bfd97f82a2..38ed420ff7df 100644
--- a/net-analyzer/pinger/pinger-0.33-r1.ebuild
+++ b/net-analyzer/pinger/pinger-0.33-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -35,6 +35,7 @@ DOCS=( AUTHORS BUGS ChangeLog NEWS README )
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-musl-int-types.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_prepare() {