summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-10 03:13:37 +0000
committerSam James <sam@gentoo.org>2021-12-10 03:48:53 +0000
commit6b74ed44db7befe586920f769221134cb064adc4 (patch)
tree2508fc1c2ae685e1e3156aee2f4a67d69ab8f78c /net-analyzer/iptstate/files
parentnet-analyzer/mrtg: add 2.17.8 (diff)
downloadgentoo-6b74ed44db7befe586920f769221134cb064adc4.tar.gz
gentoo-6b74ed44db7befe586920f769221134cb064adc4.tar.bz2
gentoo-6b74ed44db7befe586920f769221134cb064adc4.zip
net-analyzer/iptstate: add 2.2.7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/iptstate/files')
-rw-r--r--net-analyzer/iptstate/files/iptstate-2.2.7-respect-CPPFLAGS.patch18
-rw-r--r--net-analyzer/iptstate/files/iptstate-2.2.7-respect-LDFLAGS.patch18
-rw-r--r--net-analyzer/iptstate/files/iptstate-2.2.7-use-pkg-config.patch21
3 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/iptstate/files/iptstate-2.2.7-respect-CPPFLAGS.patch b/net-analyzer/iptstate/files/iptstate-2.2.7-respect-CPPFLAGS.patch
new file mode 100644
index 000000000000..6b658eac80bb
--- /dev/null
+++ b/net-analyzer/iptstate/files/iptstate-2.2.7-respect-CPPFLAGS.patch
@@ -0,0 +1,18 @@
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Dec 2021 03:19:45 +0000
+Subject: [PATCH 3/3] Makefile: don't override CPPFLAGS
+
+There's no need to explicitly blank this and it prevents overrides
+from the environment.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -26,7 +26,6 @@ CXXFILES?= iptstate.cc
+
+ # THIS IS FOR NORMAL COMPILATION
+ LIBS?= $(shell $(PKG_CONFIG) --libs ncurses libnetfilter_conntrack)
+-CPPFLAGS=
+
+ ### YOU SHOULDN'T NEED TO CHANGE ANYTHING BELOW THIS
+
diff --git a/net-analyzer/iptstate/files/iptstate-2.2.7-respect-LDFLAGS.patch b/net-analyzer/iptstate/files/iptstate-2.2.7-respect-LDFLAGS.patch
new file mode 100644
index 000000000000..41c875453926
--- /dev/null
+++ b/net-analyzer/iptstate/files/iptstate-2.2.7-respect-LDFLAGS.patch
@@ -0,0 +1,18 @@
+https://github.com/jaymzh/iptstate/pull/21
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Dec 2021 03:10:49 +0000
+Subject: [PATCH 1/2] Makefile: respect LDFLAGS
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -49,7 +49,7 @@ iptstate: iptstate.cc Makefile
+ echo "+------------------------------------------------------------+" ;\
+ echo "";
+
+- $(CXX) $(CXXFLAGS) $(CXXFILES) -o iptstate $(LIBS) $(CPPFLAGS)
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $(CXXFILES) -o iptstate $(LIBS)
+ @touch iptstate
+
+ @\
diff --git a/net-analyzer/iptstate/files/iptstate-2.2.7-use-pkg-config.patch b/net-analyzer/iptstate/files/iptstate-2.2.7-use-pkg-config.patch
new file mode 100644
index 000000000000..3896799f78ae
--- /dev/null
+++ b/net-analyzer/iptstate/files/iptstate-2.2.7-use-pkg-config.patch
@@ -0,0 +1,21 @@
+https://github.com/jaymzh/iptstate/pull/21
+
+From: Sam James <sam@gentoo.org>
+Date: Fri, 10 Dec 2021 03:10:42 +0000
+Subject: [PATCH 2/2] Makefile: Use pkg-config
+
+Depending on platform, linking against ncurses may require -ltinfo as well,
+and linking against netfilter_conntrack may require -lnetfilter too.
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,7 @@ CXXFLAGS?= -g -Wall -O2 -Werror=format-security -Wformat-truncation=0
+ CXXFILES?= iptstate.cc
+
+ # THIS IS FOR NORMAL COMPILATION
+-LIBS?= -lncurses -lnetfilter_conntrack
++LIBS?= $(shell $(PKG_CONFIG) --libs ncurses libnetfilter_conntrack)
+ CPPFLAGS=
+
+ ### YOU SHOULDN'T NEED TO CHANGE ANYTHING BELOW THIS