summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-25 05:48:56 +0000
committerSam James <sam@gentoo.org>2023-03-25 05:51:54 +0000
commitdb26ce81811d5556c2c3afc877fe42854835be7e (patch)
tree1ff9a257c4e3dea444988847dd3217f4b2006aa0 /net-analyzer/ettercap
parentmedia-libs/openal: dropped obsolete 1.22.2-r1 (diff)
downloadgentoo-db26ce81811d5556c2c3afc877fe42854835be7e.tar.gz
gentoo-db26ce81811d5556c2c3afc877fe42854835be7e.tar.bz2
gentoo-db26ce81811d5556c2c3afc877fe42854835be7e.zip
net-analyzer/ettercap: fix build w/ curl 8
Closes: https://bugs.gentoo.org/902987 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/ettercap')
-rw-r--r--net-analyzer/ettercap/ettercap-0.8.3.1-r1.ebuild (renamed from net-analyzer/ettercap/ettercap-0.8.3.1.ebuild)40
-rw-r--r--net-analyzer/ettercap/ettercap-9999.ebuild38
-rw-r--r--net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch32
3 files changed, 81 insertions, 29 deletions
diff --git a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild b/net-analyzer/ettercap/ettercap-0.8.3.1-r1.ebuild
index 9cda1724861c..5e686a896922 100644
--- a/net-analyzer/ettercap/ettercap-0.8.3.1.ebuild
+++ b/net-analyzer/ettercap/ettercap-0.8.3.1-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
@@ -22,9 +22,10 @@ fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
+RDEPEND="
+ dev-libs/libbsd
dev-libs/libpcre
- dev-libs/openssl:0=
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
@@ -39,13 +40,23 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
- test? ( dev-libs/check )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
sys-devel/flex
- app-alternatives/yacc"
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+ test? ( dev-libs/check )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-curl-8.patch
+)
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -66,8 +77,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}
diff --git a/net-analyzer/ettercap/ettercap-9999.ebuild b/net-analyzer/ettercap/ettercap-9999.ebuild
index b050ccc4f5d7..c56915d82186 100644
--- a/net-analyzer/ettercap/ettercap-9999.ebuild
+++ b/net-analyzer/ettercap/ettercap-9999.ebuild
@@ -1,30 +1,31 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit cmake
-DESCRIPTION="A suite for man in the middle attacks"
+DESCRIPTION="Suite for man in the middle attacks"
HOMEPAGE="https://github.com/Ettercap/ettercap"
LICENSE="GPL-2+"
SLOT="0"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Ettercap/${PN}.git"
else
SRC_URI="https://github.com/Ettercap/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha amd64 arm ppc ppc64 sparc x86"
fi
IUSE="doc geoip gtk ipv6 ncurses +plugins test"
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/libbsd
+RDEPEND="
+ dev-libs/libbsd
dev-libs/libpcre
- dev-libs/openssl:0=
+ dev-libs/openssl:=
net-libs/libnet:1.1
>=net-libs/libpcap-0.8.1
sys-libs/zlib
@@ -39,13 +40,19 @@ RDEPEND="dev-libs/libbsd
>=x11-libs/pango-1.2.3
)
ncurses? ( >=sys-libs/ncurses-5.3:= )
- plugins? ( >=net-misc/curl-7.26.0 )"
-DEPEND="${RDEPEND}
- doc? ( app-text/ghostscript-gpl
- sys-apps/groff )
- test? ( dev-libs/check )
+ plugins? ( >=net-misc/curl-7.26.0 )
+"
+DEPEND="
+ app-alternatives/yacc
sys-devel/flex
- app-alternatives/yacc"
+"
+BDEPEND="
+ doc? (
+ app-text/ghostscript-gpl
+ sys-apps/groff
+ )
+ test? ( dev-libs/check )
+"
src_prepare() {
sed -i "s:Release:Release Gentoo:" CMakeLists.txt || die
@@ -66,8 +73,9 @@ src_configure() {
-DINSTALL_SYSCONFDIR="${EPREFIX}"/etc
)
+ # right now we only support gtk2, but ettercap also supports gtk3
+ # do we care? do we want to support both?
! use gtk && mycmakeargs+=(-DINSTALL_DESKTOP=OFF)
- #right now we only support gtk2, but ettercap also supports gtk3
- #do we care? do we want to support both?
+
cmake_src_configure
}
diff --git a/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
new file mode 100644
index 000000000000..e1c2259733c2
--- /dev/null
+++ b/net-analyzer/ettercap/files/ettercap-0.8.3.1-curl-8.patch
@@ -0,0 +1,32 @@
+https://bugs.gentoo.org/902987
+https://github.com/Ettercap/ettercap/commit/40534662043b7d831d1f6c70448afa9d374a9b63
+
+From 40534662043b7d831d1f6c70448afa9d374a9b63 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 23 Mar 2023 10:23:14 -0700
+Subject: [PATCH] sslstrip: Enhance the libcurl version check to consider
+ version 8+
+
+Lately curl has released version 8 and hence LIBCURL_VERSION_MAJOR is
+reset to 0, current check assumes major version to be 7 at max and hence
+on systems with libcurl 8+ this check breaks and build fails
+
+Fixes
+
+TOPDIR/build/tmp/work/cortexa15t2hf-neon-yoe-linux-gnueabi/ettercap/0.8.3.1-r0/git/plug-ins/sslstrip/sslstrip.c:57:2: error: libcurl 7.26.0 or up is needed
+ ^
+1 error generated.
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/plug-ins/sslstrip/sslstrip.c
++++ b/plug-ins/sslstrip/sslstrip.c
+@@ -51,7 +51,7 @@
+
+ #include <curl/curl.h>
+
+-#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MINOR < 26)
++#if (LIBCURL_VERSION_MAJOR < 7) || (LIBCURL_VERSION_MAJOR == 7 && LIBCURL_VERSION_MINOR < 26)
+ #error libcurl 7.26.0 or up is needed
+ #endif
+
+