summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-27 14:44:35 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:39 +0200
commit1c669f2ad1d54ad5bdd9bd04d99a63c8c1f4cfa2 (patch)
tree10bca0ee5e531c7a625a9411b93bbab1b28ee401 /net-analyzer/alive/alive-2.0.5-r100.ebuild
parentmedia-sound/lilypond: update live to use new guile mechanism (diff)
downloadgentoo-1c669f2ad1d54ad5bdd9bd04d99a63c8c1f4cfa2.tar.gz
gentoo-1c669f2ad1d54ad5bdd9bd04d99a63c8c1f4cfa2.tar.bz2
gentoo-1c669f2ad1d54ad5bdd9bd04d99a63c8c1f4cfa2.zip
net-analyzer/alive: switch to new guile mechanism
Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'net-analyzer/alive/alive-2.0.5-r100.ebuild')
-rw-r--r--net-analyzer/alive/alive-2.0.5-r100.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-analyzer/alive/alive-2.0.5-r100.ebuild b/net-analyzer/alive/alive-2.0.5-r100.ebuild
new file mode 100644
index 000000000000..277a47bb198a
--- /dev/null
+++ b/net-analyzer/alive/alive-2.0.5-r100.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile-single unpacker
+
+DESCRIPTION="Periodic ping program"
+HOMEPAGE="https://www.gnu.org/software/alive/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+DEPEND="${GUILE_DEPS}"
+RDEPEND="${DEPEND}
+ dev-scheme/xdgdirs
+ net-misc/iputils"
+BDEPEND="$(unpacker_src_uri_depends)"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.2-ping-test.patch
+)
+
+src_prepare() {
+ guile-single_src_prepare
+
+ eautoreconf
+}