summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-01-24 10:26:14 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-01-24 10:26:24 +0100
commitd7af1aa9891fc1b14bcb1aa48d2d4694493c3088 (patch)
tree5bd4e3c87e9922f7ebed280918b9e14022ac082d /media-sound
parentdev-ruby/rails-html-sanitizer: enable ruby33 (diff)
downloadgentoo-d7af1aa9891fc1b14bcb1aa48d2d4694493c3088.tar.gz
gentoo-d7af1aa9891fc1b14bcb1aa48d2d4694493c3088.tar.bz2
gentoo-d7af1aa9891fc1b14bcb1aa48d2d4694493c3088.zip
media-sound/qjackctl: bump to 0.9.13
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/qjackctl/Manifest1
-rw-r--r--media-sound/qjackctl/files/qjackctl-0.9.13-disable-git.patch20
-rw-r--r--media-sound/qjackctl/qjackctl-0.9.13.ebuild47
3 files changed, 68 insertions, 0 deletions
diff --git a/media-sound/qjackctl/Manifest b/media-sound/qjackctl/Manifest
index 18a38ea3c126..1485206c04dc 100644
--- a/media-sound/qjackctl/Manifest
+++ b/media-sound/qjackctl/Manifest
@@ -1 +1,2 @@
DIST qjackctl-0.9.12.tar.gz 1277827 BLAKE2B 1fcfba82762c473f0012a137f6ddd13ae6e857d16fe8e0cad449afe6de1f1feb8a147b3441a00d20d887f1ed868e4fdddc598104f829ab2213ca8e9863c16951 SHA512 e5655b4f4a965761b81d2d08c1ad297bda6d2437aff97127dc22015f59fe916f1b10f4f492fe41b0d0678ed9de2a94de16c195ac608fb01e815e3ecb116bf958
+DIST qjackctl-0.9.13.tar.gz 1305333 BLAKE2B 940241df829a573ab33a950319debf5123538151853723141369b9ac47048bae84c58f3a70fe53ec7f98109914e78c49203410e241db22842c4f41f79ab6aba9 SHA512 89b9d5212654267030f30020085ad3dfe674a041e200796144d1441ba12630e963a06e405de5ab7c27d9ebc42fd8fa0a970bf59b91837dbc7580147db6adc9bc
diff --git a/media-sound/qjackctl/files/qjackctl-0.9.13-disable-git.patch b/media-sound/qjackctl/files/qjackctl-0.9.13-disable-git.patch
new file mode 100644
index 000000000000..ff4e69fa1762
--- /dev/null
+++ b/media-sound/qjackctl/files/qjackctl-0.9.13-disable-git.patch
@@ -0,0 +1,20 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -14,6 +14,7 @@ set (PROJECT_DOMAIN "rncbc.org")
+
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
+
++#[[
+ execute_process (
+ COMMAND git describe --tags --dirty --abbrev=6
+ WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}
+@@ -38,7 +39,8 @@ if (GIT_DESCRIBE_RESULT EQUAL 0)
+ endif ()
+ set (PROJECT_VERSION "${GIT_VERSION}")
+ endif ()
+-
++]]
++set (VERSION "${PROJECT_VERSION}")
+
+ if (CMAKE_BUILD_TYPE MATCHES "Debug")
+ set (CONFIG_DEBUG 1)
diff --git a/media-sound/qjackctl/qjackctl-0.9.13.ebuild b/media-sound/qjackctl/qjackctl-0.9.13.ebuild
new file mode 100644
index 000000000000..8e8527b28ae1
--- /dev/null
+++ b/media-sound/qjackctl/qjackctl-0.9.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg cmake
+
+DESCRIPTION="Qt GUI to control the JACK Audio Connection Kit and ALSA sequencer connections"
+HOMEPAGE="https://qjackctl.sourceforge.io/"
+SRC_URI="mirror://sourceforge/qjackctl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus debug portaudio"
+
+BDEPEND="dev-qt/linguist-tools:5"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ dev-qt/qtxml:5
+ virtual/jack
+ alsa? ( media-libs/alsa-lib )
+ dbus? ( dev-qt/qtdbus:5 )
+ portaudio? ( media-libs/portaudio )
+"
+RDEPEND="${DEPEND}
+ dev-qt/qtsvg:5
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.9.13-disable-git.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_ALSA_SEQ=$(usex alsa 1 0)
+ -DCONFIG_DBUS=$(usex dbus 1 0)
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ -DCONFIG_PORTAUDIO=$(usex portaudio 1 0)
+ -DCONFIG_QT6=no
+ )
+ cmake_src_configure
+}