summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-21 12:09:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-29 14:03:42 +0100
commitce86df7eb9cdd27b8da28b84541ed0894fac4b53 (patch)
tree3924362d6b5210d43d0502e02ac8f34b776b09c9 /media-sound
parentkde5.eclass: Switch to cmake.eclass (diff)
downloadgentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.gz
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.tar.bz2
gentoo-ce86df7eb9cdd27b8da28b84541ed0894fac4b53.zip
*/*: Switch kde proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/cantata/cantata-2.3.3-r1.ebuild6
-rw-r--r--media-sound/drumstick/drumstick-1.1.2.ebuild14
-rw-r--r--media-sound/drumstick/drumstick-1.1.3.ebuild14
-rw-r--r--media-sound/kid3/kid3-3.7.1.ebuild6
-rw-r--r--media-sound/kid3/kid3-3.8.1.ebuild6
-rw-r--r--media-sound/kmetronome/kmetronome-1.0.1.ebuild4
6 files changed, 25 insertions, 25 deletions
diff --git a/media-sound/cantata/cantata-2.3.3-r1.ebuild b/media-sound/cantata/cantata-2.3.3-r1.ebuild
index 05ee35f51094..b29c21cf2734 100644
--- a/media-sound/cantata/cantata-2.3.3-r1.ebuild
+++ b/media-sound/cantata/cantata-2.3.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PLOCALES="cs da de en_GB es fr hu it ja ko pl pt_BR ru zh_CN"
-inherit cmake-utils l10n qmake-utils xdg
+inherit cmake l10n qmake-utils xdg
DESCRIPTION="Featureful and configurable Qt client for the music player daemon (MPD)"
HOMEPAGE="https://github.com/CDrummond/cantata"
@@ -77,7 +77,7 @@ src_prepare() {
rm "translations/${PN}_${1}".ts || die
}
- cmake-utils_src_prepare
+ cmake_src_prepare
# Unbundle 3rd party libs
rm -r 3rdparty/{ebur128,qtsingleapplication} || die
@@ -106,7 +106,7 @@ src_configure() {
-DENABLE_UDISKS2=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
pkg_postinst() {
diff --git a/media-sound/drumstick/drumstick-1.1.2.ebuild b/media-sound/drumstick/drumstick-1.1.2.ebuild
index c76b61480434..cf6137ec098e 100644
--- a/media-sound/drumstick/drumstick-1.1.2.ebuild
+++ b/media-sound/drumstick/drumstick-1.1.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
HOMEPAGE="http://drumstick.sourceforge.net/"
@@ -41,7 +41,7 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
RESTRICT="test"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use fluidsynth ; then
sed -i -e "/pkg_check_modules(FLUIDSYNTH/d" \
@@ -58,19 +58,19 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=OFF
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doxygen
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc ; then
dodoc -r "${BUILD_DIR}"/doc/html
diff --git a/media-sound/drumstick/drumstick-1.1.3.ebuild b/media-sound/drumstick/drumstick-1.1.3.ebuild
index f6de2bd3fcc8..fbb7e14743ec 100644
--- a/media-sound/drumstick/drumstick-1.1.3.ebuild
+++ b/media-sound/drumstick/drumstick-1.1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Qt/C++ wrapper for ALSA sequencer"
HOMEPAGE="http://drumstick.sourceforge.net/"
@@ -41,7 +41,7 @@ DOCS=( AUTHORS ChangeLog NEWS README TODO )
RESTRICT="test"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
if ! use fluidsynth ; then
sed -i -e "/pkg_check_modules(FLUIDSYNTH/d" \
@@ -58,19 +58,19 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=OFF
- $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake_use_find_package doc Doxygen)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doxygen
+ cmake_src_compile
+ use doc && cmake_src_compile doxygen
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc ; then
dodoc -r "${BUILD_DIR}"/doc/html
diff --git a/media-sound/kid3/kid3-3.7.1.ebuild b/media-sound/kid3/kid3-3.7.1.ebuild
index 87343373f369..172085a01f3f 100644
--- a/media-sound/kid3/kid3-3.7.1.ebuild
+++ b/media-sound/kid3/kid3-3.7.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Simple tag editor based on Qt"
HOMEPAGE="https://kid3.sourceforge.io/"
@@ -58,7 +58,7 @@ RDEPEND="${DEPEND}
src_prepare() {
# overengineered upstream build system
- cmake-utils_src_prepare
+ cmake_src_prepare
# applies broken python hacks, bug #614950
cmake_comment_add_subdirectory doc
}
@@ -80,5 +80,5 @@ src_configure() {
mycmakeargs+=( "-DWITH_APPS=Qt;CLI" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-sound/kid3/kid3-3.8.1.ebuild b/media-sound/kid3/kid3-3.8.1.ebuild
index 9b1848ffad55..5fdb33123072 100644
--- a/media-sound/kid3/kid3-3.8.1.ebuild
+++ b/media-sound/kid3/kid3-3.8.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="Simple tag editor based on Qt"
HOMEPAGE="https://kid3.sourceforge.io/"
@@ -59,7 +59,7 @@ RDEPEND="${DEPEND}
src_prepare() {
# overengineered upstream build system
- cmake-utils_src_prepare
+ cmake_src_prepare
# applies broken python hacks, bug #614950
cmake_comment_add_subdirectory doc
}
@@ -81,5 +81,5 @@ src_configure() {
mycmakeargs+=( "-DWITH_APPS=Qt;CLI" )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/media-sound/kmetronome/kmetronome-1.0.1.ebuild b/media-sound/kmetronome/kmetronome-1.0.1.ebuild
index 8adf01c87da4..d690d4807621 100644
--- a/media-sound/kmetronome/kmetronome-1.0.1.ebuild
+++ b/media-sound/kmetronome/kmetronome-1.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils xdg
+inherit cmake xdg
DESCRIPTION="MIDI based metronome using ALSA sequencer"
HOMEPAGE="http://kmetronome.sourceforge.net/"
@@ -30,5 +30,5 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
}