summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2024-03-16 10:07:46 -0500
committerErik Mackdanz <stasibear@gentoo.org>2024-03-16 10:09:18 -0500
commit651d4f84dd9f06bf52c9468e08257dfaec68e229 (patch)
treea844b02d48d9bfcc1ea254a4f3b0c26042317f35 /media-sound
parentnet-libs/libupnpp: add 0.26.3 (diff)
downloadgentoo-651d4f84dd9f06bf52c9468e08257dfaec68e229.tar.gz
gentoo-651d4f84dd9f06bf52c9468e08257dfaec68e229.tar.bz2
gentoo-651d4f84dd9f06bf52c9468e08257dfaec68e229.zip
media-sound/upmpdcli: add 1.8.9
Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.8.9.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index d8a01e1b29b8..7d2114cde2d6 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -1 +1,2 @@
DIST upmpdcli-1.8.1.tar.gz 629467 BLAKE2B dcc5f719721711e8b1ab53c8a163aa1230f01358fea54aad4e4fc7bc9e1f1442c31328f16637606fc06bebdff012c581a16f843885e2675949f2cb92a6ce6444 SHA512 35c1cc3ac215d783253b93f88a50fef2caa2d9ac541240fe58398ae062f02c4934c7b832f0159c7e542284496af59f91a59a2cfe3a0d5e2152dd40e7dec1aed7
+DIST upmpdcli-1.8.9.tar.gz 658086 BLAKE2B 61aa8752f7c2611fd27be5c8114630f9be00f84d27ad2ccbb32320cf7ba00c0dc5a983222de50f9bc361c6a695634c0c0d6896d355bc90bb26637f35bc4432be SHA512 f7fc474d91076acfe1d1482db6ea3e9a4a15612cfdef854e11721673f5822f1d2adf1b353b39bdbfbb6cbf869f4b6e8b6995c78e11555cd03c44140f4104b087
diff --git a/media-sound/upmpdcli/upmpdcli-1.8.9.ebuild b/media-sound/upmpdcli/upmpdcli-1.8.9.ebuild
new file mode 100644
index 000000000000..620cb2f7e971
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.8.9.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools systemd
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd:=
+ net-libs/libupnpp
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/upmpdcli
+ acct-user/upmpdcli
+ app-misc/recoll
+ thirdparty? ( dev-python/requests )
+"
+
+PATCHES=(
+ "${FILESDIR}"/makefile.patch
+ "${FILESDIR}"/configure.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+
+ eautoconf
+
+ ./configure \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-dependency-tracking \
+ --disable-silent-rules \
+ "--docdir=/usr/share/doc/${P}" \
+ "--htmldir=/usr/share/doc/${P}/html" \
+ --libdir=/usr/lib64 \
+ || die "Configure failed"
+
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package no longer assumes that upmpdcli is driving an"
+ einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
+ einfo "Probably it is though, so be sure your mpd is built with"
+ einfo "USE=curl."
+}