summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 15:05:26 -0400
committerSam James <sam@gentoo.org>2024-03-13 21:04:07 +0000
commit2c3538475e38700f080333f9bcc50748036b7055 (patch)
tree9677eb4bf5a4ca4518b55d1e6915ff303ac2cc01 /media-sound
parentdev-embedded/ponyprog: mark as LTO-unsafe (diff)
downloadgentoo-2c3538475e38700f080333f9bcc50748036b7055.tar.gz
gentoo-2c3538475e38700f080333f9bcc50748036b7055.tar.bz2
gentoo-2c3538475e38700f080333f9bcc50748036b7055.zip
media-sound/audiotools: work around broken parallel building
Because setuptools cannot handle two extensions that build the source code, and races. Closes: https://bugs.gentoo.org/860444 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/audiotools/audiotools-3.1.1-r2.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-sound/audiotools/audiotools-3.1.1-r2.ebuild b/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
index 3d93d632d29e..02b83872ef6f 100644
--- a/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
+++ b/media-sound/audiotools/audiotools-3.1.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -82,6 +82,12 @@ python_compile_all() {
emake -C docs
}
+python_compile() {
+ # setuptools is broken with parallel builds
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}
+
python_test() {
cd test || die
"${PYTHON}" test.py || die