summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/gejengel
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/gejengel')
-rw-r--r--media-sound/gejengel/Manifest1
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch36
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch13
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch24
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-libav9.patch21
-rw-r--r--media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch26
-rw-r--r--media-sound/gejengel/gejengel-0.1.4-r1.ebuild77
-rw-r--r--media-sound/gejengel/metadata.xml15
8 files changed, 213 insertions, 0 deletions
diff --git a/media-sound/gejengel/Manifest b/media-sound/gejengel/Manifest
new file mode 100644
index 000000000000..1c405a2ba192
--- /dev/null
+++ b/media-sound/gejengel/Manifest
@@ -0,0 +1 @@
+DIST gejengel-0.1.4.tar.gz 473674 SHA256 036a4ff2520b6ff9f73fc3012d8810939583f0dc25be6bac28689dffb6e9023b SHA512 584a6250ec87475babbeff86c7f2427cf731b3ec0906dcc6219bf40cf1c5533feaf3f076d0f34daeaa21a1c2596e5fe53e4530820a6d47dbca7f9afd6f489580 WHIRLPOOL 0afd7138782f6337bf7aa770ae8dbddf3d037978ffabf6b7f9c5fedddd6e1a3354714d9d80e7414c27b8250be8f41d7476454f2c1408b8709d063e61774d316f
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch
new file mode 100644
index 000000000000..10d43d3da1a4
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg-1.patch
@@ -0,0 +1,36 @@
+Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+===================================================================
+--- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
++++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+@@ -83,7 +83,7 @@ void FFmpegDecoder::initialise()
+ avcodec_register_all();
+ av_register_all();
+
+- if (av_open_input_file(&m_pFormatContext, m_Filepath.c_str(), NULL, 0, NULL) != 0)
++ if (avformat_open_input(&m_pFormatContext, m_Filepath.c_str(), NULL, NULL) != 0)
+ {
+ throw logic_error("Could not open input file: " + m_Filepath);
+ }
+@@ -307,21 +307,7 @@ AudioFormat FFmpegDecoder::getAudioForma
+ {
+ AudioFormat format;
+
+- switch(m_pAudioCodecContext->sample_fmt)
+- {
+- case SAMPLE_FMT_U8:
+- format.bits = 8;
+- break;
+- case SAMPLE_FMT_S16:
+- format.bits = 16;
+- break;
+- case SAMPLE_FMT_S32:
+- format.bits = 32;
+- break;
+- default:
+- format.bits = 0;
+- }
+-
++ format.bits = av_get_bytes_per_sample(m_pAudioCodecContext->sample_fmt) << 3;
+ format.rate = m_pAudioCodecContext->sample_rate;
+ format.numChannels = m_pAudioCodecContext->channels;
+ format.framesPerPacket = m_pAudioCodecContext->frame_size;
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch
new file mode 100644
index 000000000000..658ff0ca675c
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg.patch
@@ -0,0 +1,13 @@
+Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+===================================================================
+--- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
++++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+@@ -104,7 +104,7 @@ void FFmpegDecoder::initializeAudio()
+ {
+ for(uint32_t i = 0; i < m_pFormatContext->nb_streams; ++i)
+ {
+- if (m_pFormatContext->streams[i]->codec->codec_type == CODEC_TYPE_AUDIO)
++ if (m_pFormatContext->streams[i]->codec->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ m_pAudioStream = m_pFormatContext->streams[i];
+ m_AudioStream = i;
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch
new file mode 100644
index 000000000000..b6850eb2e58d
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-ffmpeg2.patch
@@ -0,0 +1,24 @@
+Index: gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+===================================================================
+--- gejengel-0.1.4.orig/src/AudioDecoder/ffmpegdecoder.cpp
++++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+@@ -28,6 +28,10 @@ extern "C"
+ #include <libavcodec/avcodec.h>
+ }
+
++#ifndef AVCODEC_MAX_AUDIO_FRAME_SIZE
++#define AVCODEC_MAX_AUDIO_FRAME_SIZE 192000 // 1 second of 48khz 32bit audio
++#endif
++
+ using namespace std;
+ using namespace utils;
+
+@@ -71,7 +75,7 @@ void FFmpegDecoder::destroy()
+
+ if (m_pFormatContext)
+ {
+- av_close_input_file(m_pFormatContext);
++ avformat_close_input(&m_pFormatContext);
+ m_pFormatContext = NULL;
+ }
+
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-libav9.patch b/media-sound/gejengel/files/gejengel-0.1.4-libav9.patch
new file mode 100644
index 000000000000..5529fb7308dc
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-libav9.patch
@@ -0,0 +1,21 @@
+diff -urN gejengel-0.1.4.old/src/AudioDecoder/ffmpegdecoder.cpp gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp
+--- gejengel-0.1.4.old/src/AudioDecoder/ffmpegdecoder.cpp 2013-06-22 18:48:46.176890946 +0200
++++ gejengel-0.1.4/src/AudioDecoder/ffmpegdecoder.cpp 2013-06-22 18:50:04.516888158 +0200
+@@ -88,7 +88,7 @@
+ throw logic_error("Could not open input file: " + m_Filepath);
+ }
+
+- if (av_find_stream_info(m_pFormatContext) < 0)
++ if (avformat_find_stream_info(m_pFormatContext, NULL) < 0)
+ {
+ throw logic_error("Could not find stream information in " + m_Filepath);
+ }
+@@ -134,7 +134,7 @@
+ m_pFormatContext->flags |= AVFMT_FLAG_GENPTS;
+ m_pFormatContext->streams[m_AudioStream]->discard = AVDISCARD_DEFAULT;
+
+- if (avcodec_open(m_pAudioCodecContext, m_pAudioCodec) < 0)
++ if (avcodec_open2(m_pAudioCodecContext, m_pAudioCodec, NULL) < 0)
+ {
+ throw logic_error("Could not open audio codec for " + m_Filepath);
+ }
diff --git a/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch b/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch
new file mode 100644
index 000000000000..8026d89725c5
--- /dev/null
+++ b/media-sound/gejengel/files/gejengel-0.1.4-libnotify-0.7.patch
@@ -0,0 +1,26 @@
+--- src/Plugins/notificationplugin.cpp
++++ src/Plugins/notificationplugin.cpp
+@@ -33,6 +33,10 @@
+ #include "ui/sharedfunctions.h"
+ #include "MusicLibrary/album.h"
+
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
++
+ using namespace std;
+ using namespace Gtk;
+
+@@ -85,7 +89,12 @@
+ }
+ }
+
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ m_pNotification = notify_notification_new("dummy", "", NULL);
++#else
+ m_pNotification = notify_notification_new("dummy", "", NULL, NULL);
++#endif
++
+ notify_notification_set_timeout (m_pNotification, NOTIFY_EXPIRES_DEFAULT);
+ notify_notification_set_urgency (m_pNotification, NOTIFY_URGENCY_NORMAL);
+
diff --git a/media-sound/gejengel/gejengel-0.1.4-r1.ebuild b/media-sound/gejengel/gejengel-0.1.4-r1.ebuild
new file mode 100644
index 000000000000..db2015f6e1ff
--- /dev/null
+++ b/media-sound/gejengel/gejengel-0.1.4-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Lightweight audio player"
+HOMEPAGE="http://code.google.com/p/gejengel"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+alsa audioscrobbler debug dbus +ffmpeg flac libnotify mad openal pulseaudio syslog"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ dev-cpp/pangomm:1.4
+ media-libs/taglib
+ dev-db/sqlite:3
+ || ( media-gfx/imagemagick[cxx]
+ media-gfx/graphicsmagick[imagemagick] )
+ mad? ( media-libs/libmad )
+ flac? ( media-libs/flac[cxx] )
+ ffmpeg? ( >=virtual/ffmpeg-9 )
+ audioscrobbler? ( >=media-libs/lastfmlib-0.4 )
+ dbus? ( dev-libs/dbus-glib )
+ libnotify? ( x11-libs/libnotify )
+ openal? ( media-libs/openal )
+ alsa? ( media-libs/alsa-lib )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ dev-libs/libxdg-basedir
+ dev-util/intltool
+ >=sys-devel/automake-1.11"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch \
+ "${FILESDIR}"/${P}-ffmpeg.patch \
+ "${FILESDIR}"/${P}-ffmpeg-1.patch \
+ "${FILESDIR}"/${P}-libav9.patch \
+ "${FILESDIR}"/${P}-ffmpeg2.patch
+ # Remove Vesion and Encoding from the desktop file
+ sed -i -e "/Version/d" -e "/Encoding/d" \
+ data/${PN}.desktop.in || die "sed failed"
+ append-cxxflags "-D__STDC_CONSTANT_MACROS"
+}
+
+src_configure() {
+ econf \
+ --disable-shared \
+ $(use_enable syslog logging) \
+ $(use_enable debug) \
+ $(use_enable openal) \
+ $(use_enable audioscrobbler lastfm) \
+ $(use_enable dbus) \
+ $(use_enable libnotify) \
+ $(use_enable mad) \
+ $(use_enable flac) \
+ $(use_enable ffmpeg) \
+ $(use_enable alsa) \
+ $(use_enable pulseaudio) \
+ --disable-unittests
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ default
+ # The libgejengel.a is used by the package when building but shouldn't end
+ # up in the installation target
+ rm -f "${ED}"usr/$(get_libdir)/libgejengel.{a,la}
+}
diff --git a/media-sound/gejengel/metadata.xml b/media-sound/gejengel/metadata.xml
new file mode 100644
index 000000000000..d9fbae1396c9
--- /dev/null
+++ b/media-sound/gejengel/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="audioscrobbler">Enable track submission on last.fm</flag>
+ </use>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">gejengel</remote-id>
+ </upstream>
+</pkgmetadata>