summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-05 16:27:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-05 16:27:50 +0200
commit655894f94f348402d11e21e42fb8654c8a291df4 (patch)
tree07c9d562614ffb8e307a3131092d1aef09d78261 /media-libs/libogg
parentmedia-libs/harfbuzz: ia64 stable wrt bug #693512 (diff)
downloadgentoo-655894f94f348402d11e21e42fb8654c8a291df4.tar.gz
gentoo-655894f94f348402d11e21e42fb8654c8a291df4.tar.bz2
gentoo-655894f94f348402d11e21e42fb8654c8a291df4.zip
media-libs/libogg: Bump to version 1.3.4
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'media-libs/libogg')
-rw-r--r--media-libs/libogg/Manifest1
-rw-r--r--media-libs/libogg/libogg-1.3.4.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/libogg/Manifest b/media-libs/libogg/Manifest
index 4db285ec0a71..2d9c7f20cf97 100644
--- a/media-libs/libogg/Manifest
+++ b/media-libs/libogg/Manifest
@@ -1 +1,2 @@
DIST libogg-1.3.3.tar.xz 417636 BLAKE2B 2fc69580ed94be520c8e6b764e6271ec60e9d83d4265ca0408df4b2e6233a0f1d68e79400bc3871cc130034697ba97cedc453a574b9c6f618c9b819a93a2d3e8 SHA512 37d8e4329bf7a997a95d84a55c325a5a893ec84bb4d5b7ea638e5cb13201a0619e71ecd9710a8371def69f092c62dcc59ec0a607db246028ee8a62678386260b
+DIST libogg-1.3.4.tar.xz 428696 BLAKE2B 21814db2d45e32be56da1b56afacce4b906b34c7b71e7915ceb7b4a240b9a1c271085a4d19362c97c5bb825569094bd2940a92140204f0449eeeadaa40cc6b30 SHA512 09ffb72c3cbde5c05140f5879bd457106ed4070bd7aa5ea7720cf8910167f1d0fa6312f1f71625d51f21e3033219da858e1a8a2701bfd768b35061f7586f976c
diff --git a/media-libs/libogg/libogg-1.3.4.ebuild b/media-libs/libogg/libogg-1.3.4.ebuild
new file mode 100644
index 000000000000..87444316d676
--- /dev/null
+++ b/media-libs/libogg/libogg-1.3.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit multilib-minimal
+
+DESCRIPTION="the Ogg media file format library"
+HOMEPAGE="https://xiph.org/ogg/"
+SRC_URI="https://downloads.xiph.org/releases/ogg/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+DOCS=( AUTHORS CHANGES )
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/ogg/config_types.h
+)
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
+ $(use_enable static-libs static)
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -type f -name "*.la" -delete || die
+}