summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-30 21:03:10 +0000
committerSam James <sam@gentoo.org>2024-12-30 21:03:48 +0000
commitb9c3d958486a08d3b1dd7b7c2c645a81d123f947 (patch)
tree405eaefe53a5ad9577adeda672e73d80f461180d /media-libs/ftgl
parentxfce-extra/thunar-vcs-plugin: Bump to 0.3.0 (diff)
downloadgentoo-b9c3d958486a08d3b1dd7b7c2c645a81d123f947.tar.gz
gentoo-b9c3d958486a08d3b1dd7b7c2c645a81d123f947.tar.bz2
gentoo-b9c3d958486a08d3b1dd7b7c2c645a81d123f947.zip
media-libs/ftgl: change freetype-2.13.3 patch
We can't change the type as the previous patch did as it breaks ABI. Closes: https://bugs.gentoo.org/937849 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/ftgl')
-rw-r--r--media-libs/ftgl/files/ftgl-2.1.3_rc5-freetype-2.13.3.patch39
-rw-r--r--media-libs/ftgl/ftgl-2.1.3_rc5-r3.ebuild (renamed from media-libs/ftgl/ftgl-2.1.3_rc5-r2.ebuild)2
2 files changed, 2 insertions, 39 deletions
diff --git a/media-libs/ftgl/files/ftgl-2.1.3_rc5-freetype-2.13.3.patch b/media-libs/ftgl/files/ftgl-2.1.3_rc5-freetype-2.13.3.patch
index d22b25757fa6..a1a5263e8c09 100644
--- a/media-libs/ftgl/files/ftgl-2.1.3_rc5-freetype-2.13.3.patch
+++ b/media-libs/ftgl/files/ftgl-2.1.3_rc5-freetype-2.13.3.patch
@@ -1,40 +1,4 @@
https://bugs.gentoo.org/937849
-
---- a/src/FTContour.cpp
-+++ b/src/FTContour.cpp
-@@ -163,7 +163,7 @@ void FTContour::SetParity(int parity)
- }
-
-
--FTContour::FTContour(FT_Vector* contour, char* tags, unsigned int n)
-+FTContour::FTContour(FT_Vector* contour, FTContour::PointTagsType tags, unsigned int n)
- {
- FTPoint prev, cur(contour[(n - 1) % n]), next(contour[0]);
- FTPoint a, b = next - cur;
---- a/src/FTContour.h
-+++ b/src/FTContour.h
-@@ -44,6 +44,12 @@
- */
- class FTContour
- {
-+#if (FREETYPE_MAJOR * 1000 + FREETYPE_MINOR) * 1000 + FREETYPE_PATCH < 2013003
-+ typedef char* PointTagsType;
-+#else
-+ typedef unsigned char* PointTagsType;
-+#endif
-+
- public:
- /**
- * Constructor
-@@ -52,7 +58,7 @@ class FTContour
- * @param pointTags
- * @param numberOfPoints
- */
-- FTContour(FT_Vector* contour, char* pointTags, unsigned int numberOfPoints);
-+ FTContour(FT_Vector* contour, PointTagsType pointTags, unsigned int numberOfPoints);
-
- /**
- * Destructor
--- a/src/FTVectoriser.cpp
+++ b/src/FTVectoriser.cpp
@@ -166,7 +166,7 @@ void FTVectoriser::ProcessContours()
@@ -42,8 +6,7 @@ https://bugs.gentoo.org/937849
{
FT_Vector* pointList = &outline.points[startIndex];
- char* tagList = &outline.tags[startIndex];
-+ auto tagList = &outline.tags[startIndex];
++ char* tagList = reinterpret_cast<char*>(&outline.tags[startIndex]);
endIndex = outline.contours[i];
contourLength = (endIndex - startIndex) + 1;
-
diff --git a/media-libs/ftgl/ftgl-2.1.3_rc5-r2.ebuild b/media-libs/ftgl/ftgl-2.1.3_rc5-r3.ebuild
index 0fb8b7874d6b..88763e539d70 100644
--- a/media-libs/ftgl/ftgl-2.1.3_rc5-r2.ebuild
+++ b/media-libs/ftgl/ftgl-2.1.3_rc5-r3.ebuild
@@ -34,7 +34,7 @@ PATCHES=(
"${FILESDIR}"/${P}-underlink.patch
"${FILESDIR}"/${P}-freetype_pkgconfig.patch
"${FILESDIR}"/${P}-clang.patch
- "${FILESDIR}"/${P}-freetype-2.13.3.patch
+ #"${FILESDIR}"/${P}-freetype-2.13.3.patch
)
src_prepare() {