summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-16 08:18:51 +0100
committerSam James <sam@gentoo.org>2024-07-16 08:18:51 +0100
commit1d274045638c2ef671a60b5c324ea264c3f85e5b (patch)
treeb862f5290d94b67dddef449edfa48182ffbc6084 /media-gfx/superslicer/superslicer-2.5.59.8.ebuild
parentsci-geosciences/gpxsee: Stabilize 13.22 amd64, #936135 (diff)
downloadgentoo-1d274045638c2ef671a60b5c324ea264c3f85e5b.tar.gz
gentoo-1d274045638c2ef671a60b5c324ea264c3f85e5b.tar.bz2
gentoo-1d274045638c2ef671a60b5c324ea264c3f85e5b.zip
media-gfx/superslicer: add 2.5.59.8
Closes: https://bugs.gentoo.org/918510 Thanks-to: Egor <egorr.berd@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-gfx/superslicer/superslicer-2.5.59.8.ebuild')
-rw-r--r--media-gfx/superslicer/superslicer-2.5.59.8.ebuild109
1 files changed, 109 insertions, 0 deletions
diff --git a/media-gfx/superslicer/superslicer-2.5.59.8.ebuild b/media-gfx/superslicer/superslicer-2.5.59.8.ebuild
new file mode 100644
index 000000000000..b43862a3db67
--- /dev/null
+++ b/media-gfx/superslicer/superslicer-2.5.59.8.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+MY_PN="SuperSlicer"
+SLICER_PROFILES_COMMIT="8f3bb94a9c60be9a3b40d88a36ff05ba5cf2d6a8"
+
+inherit cmake wxwidgets xdg flag-o-matic
+
+DESCRIPTION="A mesh slicer to generate G-code for fused-filament-fabrication (3D printers)"
+HOMEPAGE="https://github.com/supermerill/SuperSlicer/"
+SRC_URI="
+ https://github.com/supermerill/SuperSlicer/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/slic3r/slic3r-profiles/archive/${SLICER_PROFILES_COMMIT}.tar.gz -> ${P}-profiles.tar.gz
+"
+
+LICENSE="AGPL-3 Boost-1.0 GPL-2 LGPL-3 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+RESTRICT="test"
+
+# No dep on sci-libs/libigl, in-tree version cannot build
+# static library currently. Using bundled one.
+RDEPEND="
+ dev-cpp/eigen:3
+ dev-cpp/tbb:=
+ dev-libs/boost:=[nls]
+ dev-libs/cereal
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/gmp:=
+ dev-libs/mpfr:=
+ dev-libs/imath:=
+ >=media-gfx/openvdb-8.2:=
+ net-misc/curl[adns]
+ media-libs/glew:0=
+ media-libs/libpng:0=
+ media-libs/qhull:=
+ sci-libs/nlopt
+ sci-libs/opencascade:=
+ >=sci-mathematics/cgal-5.0:=
+ sys-apps/dbus
+ sys-libs/zlib:=
+ virtual/glu
+ virtual/opengl
+ x11-libs/gtk+:3
+ x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
+"
+DEPEND="${RDEPEND}
+ media-libs/qhull[static-libs]
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.59.2-boost.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-cereal.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-dont-install-angelscript.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-gcodeviewer-symlink-fix.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-missing-includes-fix.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-openexr3.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-wxgtk3-wayland-fix.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-relax-OpenCASCADE-dep.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-link-occtwrapper-statically.patch"
+ "${FILESDIR}/${PN}-2.5.59.2-fix-dereferencing-in-std-unique_ptr-to-nullptr.patch"
+ "${FILESDIR}/${P}-additional-imports-fixes.patch"
+ "${FILESDIR}/${P}-fix-compilation-error-gnu17.patch"
+ "${FILESDIR}/${P}-libnest2d-link-xcb.patch"
+ "${FILESDIR}/${P}-boost-replace-load-string-file.patch"
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_unpack() {
+ default
+
+ mv slic3r-profiles-*/* "${S}"/resources/profiles/ || die
+}
+
+src_configure() {
+ CMAKE_BUILD_TYPE="Release"
+
+ append-flags -fno-strict-aliasing
+
+ setup-wxwidgets
+
+ local mycmakeargs=(
+ -DOPENVDB_FIND_MODULE_PATH="/usr/$(get_libdir)/cmake/OpenVDB"
+
+ -DSLIC3R_BUILD_TESTS=$(usex test)
+ -DSLIC3R_FHS=ON
+ -DSLIC3R_GTK=3
+ -DSLIC3R_GUI=ON
+ -DSLIC3R_PCH=OFF
+ -DSLIC3R_STATIC=OFF
+ -DSLIC3R_WX_STABLE=ON
+ -Wno-dev
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ rm "${ED}/usr/lib/udev/rules.d/90-3dconnexion.rules" || die
+}