summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2025-01-22 16:20:22 +0100
committerMaciej Barć <xgqt@gentoo.org>2025-01-22 17:20:52 +0100
commit22a1432a3da637b762616e2a6dfab4f5d139b3b4 (patch)
tree06e6fd11a66ad4e4047a1f8925570be14dff598c /media-gfx/curtail
parentdev-util/blueprint-compiler: remove tests failing on CI (diff)
downloadgentoo-22a1432a3da637b762616e2a6dfab4f5d139b3b4.tar.gz
gentoo-22a1432a3da637b762616e2a6dfab4f5d139b3b4.tar.bz2
gentoo-22a1432a3da637b762616e2a6dfab4f5d139b3b4.zip
media-gfx/curtail: bump to 1.12.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'media-gfx/curtail')
-rw-r--r--media-gfx/curtail/Manifest1
-rw-r--r--media-gfx/curtail/curtail-1.12.0.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/curtail/Manifest b/media-gfx/curtail/Manifest
index 0c815036aa37..54574a1d99c7 100644
--- a/media-gfx/curtail/Manifest
+++ b/media-gfx/curtail/Manifest
@@ -1 +1,2 @@
DIST curtail-1.11.1.tar.gz 208910 BLAKE2B 6a8ed78ba5e09242d0ae497541d41e310b18c6a26cdc5292503d15c003b1e265ee79e6ca057964aac0782041efcbf2beeb16912802aff534465ea0e96c0a750d SHA512 d59bcad4e774a9aa1d195f6b18964d05e41b47e81cd6fcdd86638488c0a63702c0c2ee97e20712eed4e81a0de562b7218df5519573707ace53191c14ac875b86
+DIST curtail-1.12.0.tar.gz 223113 BLAKE2B 43521421e184e484a35938aae918c580298314cf8da877f593578183ad5849765a7ae7c4436d719b6d0ef00bc70c00ada625d5893fd41dba24c681c5f7f4362e SHA512 2d7d7db0a3f804653ba0fd5510dd3d51cfe5504b89fddb6c08b5ec8062e27dc76add63030ddc7b22bddd809655c7800e438c67afaf034dca772fe9d92bfae45e
diff --git a/media-gfx/curtail/curtail-1.12.0.ebuild b/media-gfx/curtail/curtail-1.12.0.ebuild
new file mode 100644
index 000000000000..d2791e61121b
--- /dev/null
+++ b/media-gfx/curtail/curtail-1.12.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..13} )
+
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Image compressor, supporting PNG, JPEG and WebP"
+HOMEPAGE="https://github.com/Huluti/Curtail/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/Huluti/${PN^}.git"
+else
+ SRC_URI="https://github.com/Huluti/${PN^}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${P^}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="test" # Just desktop / schema / appstream file validation (fails).
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+"
+RDEPEND+="
+ >=gui-libs/libadwaita-1.3.1
+ media-gfx/jpegoptim
+ media-gfx/oxipng
+ media-gfx/pngquant
+ media-libs/libwebp
+"
+
+DOCS=( CHANGELOG.md README.md )
+
+src_prepare() {
+ sed -i "s|@PYTHON@|${PYTHON}|" "${S}/src/${PN}.in" || die
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}