summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /mail-filter/spamdyke
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'mail-filter/spamdyke')
-rw-r--r--mail-filter/spamdyke/Manifest1
-rw-r--r--mail-filter/spamdyke/files/spamdyke-4.3.0-gcc46.patch10
-rw-r--r--mail-filter/spamdyke/metadata.xml18
-rw-r--r--mail-filter/spamdyke/spamdyke-4.3.0.ebuild77
4 files changed, 106 insertions, 0 deletions
diff --git a/mail-filter/spamdyke/Manifest b/mail-filter/spamdyke/Manifest
new file mode 100644
index 000000000000..67c97f328b11
--- /dev/null
+++ b/mail-filter/spamdyke/Manifest
@@ -0,0 +1 @@
+DIST spamdyke-4.3.0.tgz 525399 RMD160 cbe6007ed7022e2546078ea06a7fd1f3425c50a0 SHA1 709febd5eb5852d21e8189a496d9c16120aaaee2 SHA256 6a217cfd513c3414d859cc107cc7528f94b1c452764ed192ef5774eddf4111c3
diff --git a/mail-filter/spamdyke/files/spamdyke-4.3.0-gcc46.patch b/mail-filter/spamdyke/files/spamdyke-4.3.0-gcc46.patch
new file mode 100644
index 000000000000..f9428bee6bf0
--- /dev/null
+++ b/mail-filter/spamdyke/files/spamdyke-4.3.0-gcc46.patch
@@ -0,0 +1,10 @@
+--- configure.ac.old 2011-04-07 09:37:58.000000000 +0200
++++ configure.ac 2011-04-07 09:38:12.000000000 +0200
+@@ -22,7 +22,6 @@
+ AC_CONFIG_HEADER([config.h])
+
+ AC_LANG_WERROR
+-CFLAGS=-Wall
+
+ # Checks for programs.
+ AC_PROG_CC([[gcc]])
diff --git a/mail-filter/spamdyke/metadata.xml b/mail-filter/spamdyke/metadata.xml
new file mode 100644
index 000000000000..151d9449c37c
--- /dev/null
+++ b/mail-filter/spamdyke/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>qmail</herd>
+<longdescription lang="en">
+spamdyke is a filter for monitoring and intercepting SMTP connections between a
+remote host and a qmail server. Spam is blocked while the remote server
+(spammer) is still connected; no additional processing or storage is needed.
+
+In addition to all of its anti-spam filters, spamdyke also includes a number of
+features to enhance qmail.
+
+Best of all, using spamdyke does not require patching or recompiling qmail!
+</longdescription>
+<use>
+ <flag name='tls'>Enables TLS protocol for spamdyke</flag>
+</use>
+</pkgmetadata>
diff --git a/mail-filter/spamdyke/spamdyke-4.3.0.ebuild b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
new file mode 100644
index 000000000000..e3491cace8b0
--- /dev/null
+++ b/mail-filter/spamdyke/spamdyke-4.3.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils autotools
+
+DESCRIPTION="A drop-in connection-time spam filter for qmail"
+HOMEPAGE="http://www.spamdyke.org/"
+SRC_URI="http://www.spamdyke.org/releases/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+tls"
+
+DEPEND="tls? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+S=${WORKDIR}/${P}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc46.patch
+ echo "# Configuration option for ${PN}" > ${PN}.conf
+ if use tls; then
+ echo "tls-certificate-file=/var/qmail/control/clientcert.pem" \
+ >> ${PN}.conf
+ fi
+ echo "graylist-level=always-create-dir" >> ${PN}.conf
+ echo "graylist-dir=/var/tmp/${PN}/graylist" >> ${PN}.conf
+ echo "reject-empty-rdns" >> ${PN}.conf
+ echo "reject-unresolvable-rdns" >> ${PN}.conf
+ echo "dns-blacklist-entry=zen.spamhaus.org" >> ${PN}.conf
+ echo "local-domains-file=/var/qmail/control/rcpthosts" >> ${PN}.conf
+ sed -i \
+ -e "/STRIP_CMD/d" \
+ Makefile.in || die "sed on Makefile.in failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable tls) || die "econf failed"
+ cd ../utils
+ econf || die "econf failed in utils"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+ cd ../utils
+ emake CFLAGS="${CFLAGS}" || die "emake in utils died"
+}
+
+src_install() {
+ dobin ${PN} || die "Installing ${PN} binary failed"
+ insinto /etc/${PN}
+ doins ${PN}.conf || die "Installing ${PN} configuration file failed"
+ dodir /var/tmp/${PN}/graylist
+ fowners -R qmaild /var/tmp/${PN}/graylist
+ cd ../utils
+ dobin domain2path || die "Installing domain2path binary failed"
+ cd ../documentation
+ dodoc {Changelog,INSTALL,UPGRADING}.txt
+ dohtml FAQ.html \
+ README.html \
+ README_ip_file_format.html \
+ README_rdns_directory_format.html \
+ README_rdns_file_format.html
+}
+
+pkg_postinst() {
+ elog "In /var/qmail/control/conf-smtpd insert the line:"
+ elog "QMAIL_SMTP_PRE=\"${QMAIL_SMTP_PRE} spamdyke -f /etc/${PN}/${PN}.conf\""
+ elog "Run spamdyke with the '-h' flag to see the available options and"
+ elog "update /etc/spamdyke/spamdyke.conf accordingly"
+}