summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-06 13:06:18 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-06 13:22:55 +0100
commitc7c68b0ef24b4a08e9ab2a2267aa3e4cd9e57f27 (patch)
treed44a5c3e9dc6e78f083a55c12b97c78e74ef38cf /mail-client
parentnet-misc/electrum-ltc: fix for qt5 disabled (diff)
downloadgentoo-c7c68b0ef24b4a08e9ab2a2267aa3e4cd9e57f27.tar.gz
gentoo-c7c68b0ef24b4a08e9ab2a2267aa3e4cd9e57f27.tar.bz2
gentoo-c7c68b0ef24b4a08e9ab2a2267aa3e4cd9e57f27.zip
mail-client/mail-notification: Remove linguas_* from IUSE.
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'mail-client')
-rw-r--r--mail-client/mail-notification/mail-notification-5.4-r10.ebuild23
1 files changed, 11 insertions, 12 deletions
diff --git a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild b/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
index 6a021824142e..4c0b026eefaf 100644
--- a/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
+++ b/mail-client/mail-notification/mail-notification-5.4-r10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,9 +17,6 @@ LICENSE="GPL-3"
IUSE="+gnome-keyring libressl sasl ssl sylpheed"
LANGS="bg ca cs de es fr ja nl pl pt pt_BR ru sr sr@Latn sv"
-for lang in ${LANGS}; do
- IUSE+=" linguas_${lang}"
-done
# gmime is actually optional, but it's used by so much of the package
# it's pointless making it optional. gnome-keyring is required for
@@ -100,12 +97,14 @@ src_install() {
einstalldocs
rm -rf "${ED}/var/lib/scrollkeeper"
- einfo "Cleaning up locales..."
- for lang in ${LANGS}; do
- use "linguas_${lang}" && {
- einfo "- keeping ${lang}"
- continue
- }
- rm -Rf "${D}"/usr/share/locale/"${lang}" || die
- done
+ if [[ -n ${LINGUAS+set} ]]; then
+ einfo "Cleaning up locales..."
+ for lang in ${LANGS}; do
+ if has ${lang} ${LINGUAS}; then
+ einfo "- keeping ${lang}"
+ else
+ rm -Rf "${D}"/usr/share/locale/"${lang}" || die
+ fi
+ done
+ fi
}