summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-09 16:16:19 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-09 16:26:34 +0100
commitce06430cc16ea24ae1b63dc3a9c44412ea632b7a (patch)
tree6a2fd5c088f41d36a1d140a0bbada960a0c1f341 /llvm-core
parentprofiles/desc: add cpu_flags_arm_sve2 (diff)
downloadgentoo-ce06430cc16ea24ae1b63dc3a9c44412ea632b7a.tar.gz
gentoo-ce06430cc16ea24ae1b63dc3a9c44412ea632b7a.tar.bz2
gentoo-ce06430cc16ea24ae1b63dc3a9c44412ea632b7a.zip
llvm-core/mlir: Install libraries needed for flang tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core')
-rw-r--r--llvm-core/mlir/mlir-21.0.0.9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/llvm-core/mlir/mlir-21.0.0.9999.ebuild b/llvm-core/mlir/mlir-21.0.0.9999.ebuild
index 73ba1e3228b6..d69b14b4bb5c 100644
--- a/llvm-core/mlir/mlir-21.0.0.9999.ebuild
+++ b/llvm-core/mlir/mlir-21.0.0.9999.ebuild
@@ -65,6 +65,9 @@ check_distribution_components() {
# dylib
MLIR)
;;
+ # installed test libraries
+ MLIRTestAnalysis|MLIRTestDialect|MLIRTestIR)
+ ;;
# static libraries
MLIR*)
continue
@@ -117,6 +120,11 @@ get_distribution_components() {
mlir_c_runner_utils
mlir_float16_utils
mlir_runner_utils
+
+ # test libraries required by flang
+ MLIRTestAnalysis
+ MLIRTestDialect
+ MLIRTestIR
)
if multilib_is_native_abi; then
@@ -151,7 +159,7 @@ multilib_src_configure() {
-DLLVM_BUILD_LLVM_DYLIB=ON
-DMLIR_BUILD_MLIR_C_DYLIB=OFF
-DMLIR_LINK_MLIR_DYLIB=ON
- -DMLIR_INCLUDE_TESTS=$(usex test)
+ -DMLIR_INCLUDE_TESTS=ON
-DMLIR_INCLUDE_INTEGRATION_TESTS=OFF
-DLLVM_DISTRIBUTION_COMPONENTS=$(get_distribution_components)
# this enables installing mlir-tblgen and mlir-pdll