summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-17 22:34:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-17 22:37:22 +0100
commit4f7fabe01e510998fd17cc4c23fd3cc2e689b2f2 (patch)
tree07650f999c6ff7884b4044a59dd1b2e1320bca0f /llvm-core
parentllvm-runtimes/offload: Add 19.1.6 (diff)
downloadgentoo-4f7fabe01e510998fd17cc4c23fd3cc2e689b2f2.tar.gz
gentoo-4f7fabe01e510998fd17cc4c23fd3cc2e689b2f2.tar.bz2
gentoo-4f7fabe01e510998fd17cc4c23fd3cc2e689b2f2.zip
llvm-core/clang-runtime: Add 19.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core')
-rw-r--r--llvm-core/clang-runtime/clang-runtime-19.1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/llvm-core/clang-runtime/clang-runtime-19.1.6.ebuild b/llvm-core/clang-runtime/clang-runtime-19.1.6.ebuild
new file mode 100644
index 000000000000..156bf2451f7b
--- /dev/null
+++ b/llvm-core/clang-runtime/clang-runtime-19.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build toolchain-funcs
+
+DESCRIPTION="Meta-ebuild for clang runtime libraries"
+HOMEPAGE="https://clang.llvm.org/"
+
+LICENSE="metapackage"
+SLOT="${PV%%.*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos"
+IUSE="+compiler-rt libcxx openmp +sanitize"
+REQUIRED_USE="sanitize? ( compiler-rt )"
+
+RDEPEND="
+ compiler-rt? (
+ ~llvm-runtimes/compiler-rt-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ sanitize? (
+ ~llvm-runtimes/compiler-rt-sanitizers-${PV}:${SLOT}[abi_x86_32(+)?,abi_x86_64(+)?]
+ )
+ )
+ libcxx? ( >=llvm-runtimes/libcxx-${PV}[${MULTILIB_USEDEP}] )
+ openmp? ( >=llvm-runtimes/openmp-${PV}[${MULTILIB_USEDEP}] )
+"
+
+pkg_pretend() {
+ if tc-is-clang; then
+ ewarn "You seem to be using clang as a system compiler. As of clang-16,"
+ ewarn "upstream has turned a few warnings that commonly occur during"
+ ewarn "configure script runs into errors by default. This causes some"
+ ewarn "configure tests to start failing, sometimes resulting in silent"
+ ewarn "breakage, missing functionality or runtime misbehavior. It is"
+ ewarn "not yet clear whether the change will remain or be reverted."
+ ewarn
+ ewarn "For more information, please see:"
+ ewarn "https://discourse.llvm.org/t/configure-script-breakage-with-the-new-werror-implicit-function-declaration/65213"
+ fi
+}