summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-02-01 08:59:04 +0100
committerMichał Górny <mgorny@gentoo.org>2025-02-01 09:05:35 +0100
commit7d86dcdf1650c8c76d175e3c205205df130fb6f0 (patch)
treeb999bd5a11d4f3305b6e22444c312b4ec6102535 /llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild
parentwww-client/opera-beta: remove old (diff)
downloadgentoo-7d86dcdf1650c8c76d175e3c205205df130fb6f0.tar.gz
gentoo-7d86dcdf1650c8c76d175e3c205205df130fb6f0.tar.bz2
gentoo-7d86dcdf1650c8c76d175e3c205205df130fb6f0.zip
llvm-core/llvm-common: main is now 21*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild')
-rw-r--r--llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild b/llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild
new file mode 100644
index 000000000000..2e0edb2d0ea7
--- /dev/null
+++ b/llvm-core/llvm-common/llvm-common-21.0.0.9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common llvm.org
+
+DESCRIPTION="Common files shared between multiple slots of LLVM"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+IUSE="emacs"
+
+RDEPEND="
+ !llvm-core/llvm:0
+"
+BDEPEND="
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+LLVM_COMPONENTS=( llvm/utils )
+llvm.org_set_globals
+
+SITEFILE="50llvm-gentoo.el"
+BYTECOMPFLAGS="-L emacs"
+
+src_compile() {
+ default
+
+ use emacs && elisp-compile emacs/*.el
+}
+
+src_install() {
+ insinto /usr/share/vim/vimfiles
+ doins -r vim/*/
+ # some users may find it useful
+ newdoc vim/README README.vim
+ dodoc vim/vimrc
+
+ if use emacs ; then
+ elisp-install llvm emacs/*.{el,elc}
+ elisp-make-site-file "${SITEFILE}" llvm
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}