summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-13 01:45:36 +0100
committerSam James <sam@gentoo.org>2024-06-13 01:46:15 +0100
commitabbe800563fc9c87b9072e14387cab15feb9ab8a (patch)
tree3a460f6abcca43b9cc27caba5dd2fe302b4c1ef9 /kde-plasma
parentdev-lang/go: drop 1.21.10, 1.22.3 (diff)
downloadgentoo-abbe800563fc9c87b9072e14387cab15feb9ab8a.tar.gz
gentoo-abbe800563fc9c87b9072e14387cab15feb9ab8a.tar.bz2
gentoo-abbe800563fc9c87b9072e14387cab15feb9ab8a.zip
kde-plasma/kwin: fix USE=systemd w/ libcxx
Already merged upstream in https://invent.kde.org/plasma/kwin/-/merge_requests/5811 but filed a backport MR which is pending at https://invent.kde.org/plasma/kwin/-/merge_requests/5892. Closes: https://bugs.gentoo.org/933120 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'kde-plasma')
-rw-r--r--kde-plasma/kwin/files/kwin-6.0.90.1-libcxx.patch27
-rw-r--r--kde-plasma/kwin/kwin-6.0.90.1-r3.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/kde-plasma/kwin/files/kwin-6.0.90.1-libcxx.patch b/kde-plasma/kwin/files/kwin-6.0.90.1-libcxx.patch
new file mode 100644
index 000000000000..8ba9615adaeb
--- /dev/null
+++ b/kde-plasma/kwin/files/kwin-6.0.90.1-libcxx.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/933120
+https://invent.kde.org/plasma/kwin/-/merge_requests/5892
+
+From b9ec66615f08e2bad3928b8b207be904ab62e745 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 2 Jun 2024 00:25:26 +0100
+Subject: [PATCH] watchdog: add includes for geteuid
+
+05a3e2bad9a3baf27293f0b5ed4bef4f38952804 added `geteuid` use but didn't
+add the needed headers. This works by chance on libstdc++ systems via
+transitive includes, but it doesn't work on libc++ systems, as reported
+downstream in Gentoo at https://bugs.gentoo.org/933120.
+
+(cherry picked from commit 31a3961c4cd387aa4aa1a0c7bf197445a346e5f0)
+--- a/src/watchdog.cpp
++++ b/src/watchdog.cpp
+@@ -8,6 +8,8 @@
+ */
+
+ #include "watchdoglogging.h"
++#include <unistd.h>
++#include <sys/types.h>
+ #include <QCoreApplication>
+ #include <QTimer>
+ #include <systemd/sd-daemon.h>
+--
+GitLab
diff --git a/kde-plasma/kwin/kwin-6.0.90.1-r3.ebuild b/kde-plasma/kwin/kwin-6.0.90.1-r3.ebuild
index 5e6849f9371d..cb02d4f27603 100644
--- a/kde-plasma/kwin/kwin-6.0.90.1-r3.ebuild
+++ b/kde-plasma/kwin/kwin-6.0.90.1-r3.ebuild
@@ -118,6 +118,10 @@ BDEPEND="
"
PDEPEND=">=kde-plasma/kde-cli-tools-${PVCUT}:*"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0.90.1-libcxx.patch
+)
+
src_prepare() {
ecm_src_prepare