summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 22:07:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-16 22:10:23 +0200
commit23413d5ec9aebc47ff189a0467016dc1f51ad10c (patch)
tree83a50f531dbcc4ce84188f5961de04452e959095 /kde-frameworks
parentkde-apps/dolphin: Stabilize 23.08.5-r1 arm64, #937987 (diff)
downloadgentoo-23413d5ec9aebc47ff189a0467016dc1f51ad10c.tar.gz
gentoo-23413d5ec9aebc47ff189a0467016dc1f51ad10c.tar.bz2
gentoo-23413d5ec9aebc47ff189a0467016dc1f51ad10c.zip
kde-frameworks/purpose: Drop no longer necessary IUSE kf6compat
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks')
-rw-r--r--kde-frameworks/purpose/purpose-5.116.0-r2.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/purpose-5.116.0-r2.ebuild b/kde-frameworks/purpose/purpose-5.116.0-r2.ebuild
new file mode 100644
index 000000000000..b5e5c652d598
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.116.0-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/kservice-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ || (
+ kde-apps/kaccounts-integration:6[qt5]
+ kde-apps/kaccounts-integration:5
+ )
+ net-libs/accounts-qt[qt5(+)]
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml[qt5(+)] )
+"
+BDEPEND="kaccounts? ( dev-util/intltool )"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}