summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 12:12:17 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-15 13:58:34 +0100
commitb5f0806e00fadca2d0c9819e9ab46b0d4c2da58f (patch)
tree651d11303c1a4fdb7aae0dd382ce043ffb840404 /kde-frameworks/sonnet
parentapp-emulation/qemu: bump up to 4.2.0, bug #702036 (diff)
downloadgentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.gz
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.tar.bz2
gentoo-b5f0806e00fadca2d0c9819e9ab46b0d4c2da58f.zip
kde-frameworks: Add KDE Frameworks 5.65
Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/sonnet')
-rw-r--r--kde-frameworks/sonnet/Manifest1
-rw-r--r--kde-frameworks/sonnet/sonnet-5.65.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/sonnet/Manifest b/kde-frameworks/sonnet/Manifest
index cccdceb071ad..1c55c188a55c 100644
--- a/kde-frameworks/sonnet/Manifest
+++ b/kde-frameworks/sonnet/Manifest
@@ -1 +1,2 @@
DIST sonnet-5.64.0.tar.xz 286768 BLAKE2B 299f69e69415c75c64f38b9114611b2fc7b58d23bccbade2d062a5ce348da9bf1f169d16b7dae2748d86974151f2496bb8cb86a9113f7516d4de549abc0dd594 SHA512 37a2f17de5d47a9966452d95d2a2c82816467a6ec0c6a3318c40847b641310c568d84c6acb99f1f4a54d02e8e4b7f17e76eee36410ad194b0a33170557f1282e
+DIST sonnet-5.65.0.tar.xz 288960 BLAKE2B b4d43095628308b05d452d0561cb14815274897b1710622d989e5d181c3086919c2cd32aa73cf727cc0d6e63be44c34a207e104a3aa13afed465c479ba0d9991 SHA512 37c459d6de59d974fc8a0812d3ce55661a1c85eefa551f8c7a7d2a4b2c37f55b163f7bcea4334f6467cca65cdd7a4dd67b6217c8f167eefc56d9dbac2223e2fa
diff --git a/kde-frameworks/sonnet/sonnet-5.65.0.ebuild b/kde-frameworks/sonnet/sonnet-5.65.0.ebuild
new file mode 100644
index 000000000000..6a8424472c39
--- /dev/null
+++ b/kde-frameworks/sonnet/sonnet-5.65.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_DESIGNERPLUGIN="true"
+QTMIN=5.12.3
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for providing spell-checking through abstraction of popular backends"
+LICENSE="LGPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="aspell +hunspell nls"
+
+BDEPEND="
+ nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
+"
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ aspell? ( app-text/aspell )
+ hunspell? ( app-text/hunspell:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package aspell ASPELL)
+ $(cmake_use_find_package hunspell HUNSPELL)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # bugs: 680032
+ local myctestargs=(
+ -E "(sonnet-test_settings|sonnet-test_highlighter)"
+ )
+
+ ecm_src_test
+}