summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-09-08 13:52:36 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-09-08 14:42:32 +0200
commit89a602d0342923328163d6d7c3011b861bd9fe92 (patch)
tree860c7cc3ef853409f6002b91b5d12944a2d5c0ef /kde-apps/konsolekalendar
parentkde-apps/knotes: 22.08.1 version bump (diff)
downloadgentoo-89a602d0342923328163d6d7c3011b861bd9fe92.tar.gz
gentoo-89a602d0342923328163d6d7c3011b861bd9fe92.tar.bz2
gentoo-89a602d0342923328163d6d7c3011b861bd9fe92.zip
kde-apps/konsolekalendar: 22.08.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-22.08.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index d3cac7cf537e..aa7eeed9f077 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-22.04.3.tar.xz 237900 BLAKE2B 5f9f524a34fc934fcfea44e21584c154770d47408e37140901c14c90527cbb0430fa51d9318711362e572fa8fda710624e076596cb1446e999f978290632ac6b SHA512 781c94f2a4cdd4caec650d74efc0b8c0b2b54fbb5eca7ff6fc22190d7fca600832ac8aa6eb6b62ac3d367916d94a3512cade35b521cb5da19cda69216f06abd0
DIST akonadi-calendar-tools-22.08.0.tar.xz 238176 BLAKE2B 5531f29758f0549995797851396f1bad47723690693424281b0f9cae401c4a82e1edf6db732278acd40c15ccffbab73fd3c8221be08f2d2b259d7bd5e900f1e0 SHA512 268eb2d0d1d25adfa2c4d66255c239b2764e3cf0c265ad86a69cc5493eaa1199b46d3dd7e03fcadaf66dc5aa0088d5cae4a9df5d4a9f681359b5500b08a96e7f
+DIST akonadi-calendar-tools-22.08.1.tar.xz 238352 BLAKE2B 674c6f29ffdc1413dfc2df407d1a0decbba2a3f65a1be1e8dac3a7b05ed5a6b3599bb4160a5ff09b982f0f698bb408170756c082911fa5e7d3e8b40221e60d2b SHA512 c3c8900326e0bf7e1759379539e476aec43dbe40d3cd3aa476ca50527ec2ba2887eeb6763703a1b1cb4c89a44dda6b7a9cb999246d2a41d7a4b7679b43b5da74
diff --git a/kde-apps/konsolekalendar/konsolekalendar-22.08.1.ebuild b/kde-apps/konsolekalendar/konsolekalendar-22.08.1.ebuild
new file mode 100644
index 000000000000..491f6714e5ba
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-22.08.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}