summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-13 13:48:37 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-13 15:13:24 +0200
commit5569f1074884a9879a353bab2845177e3e71e3e2 (patch)
tree3e3eb68d561d90cb9299ada23cb262990866a15f /kde-apps/konsolekalendar
parentkde-apps/knotes: 22.08.2 version bump (diff)
downloadgentoo-5569f1074884a9879a353bab2845177e3e71e3e2.tar.gz
gentoo-5569f1074884a9879a353bab2845177e3e71e3e2.tar.bz2
gentoo-5569f1074884a9879a353bab2845177e3e71e3e2.zip
kde-apps/konsolekalendar: 22.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsolekalendar')
-rw-r--r--kde-apps/konsolekalendar/Manifest1
-rw-r--r--kde-apps/konsolekalendar/konsolekalendar-22.08.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-apps/konsolekalendar/Manifest b/kde-apps/konsolekalendar/Manifest
index fb7ae41931be..21e1d2f3fae9 100644
--- a/kde-apps/konsolekalendar/Manifest
+++ b/kde-apps/konsolekalendar/Manifest
@@ -1,2 +1,3 @@
DIST akonadi-calendar-tools-22.04.3.tar.xz 237900 BLAKE2B 5f9f524a34fc934fcfea44e21584c154770d47408e37140901c14c90527cbb0430fa51d9318711362e572fa8fda710624e076596cb1446e999f978290632ac6b SHA512 781c94f2a4cdd4caec650d74efc0b8c0b2b54fbb5eca7ff6fc22190d7fca600832ac8aa6eb6b62ac3d367916d94a3512cade35b521cb5da19cda69216f06abd0
DIST akonadi-calendar-tools-22.08.1.tar.xz 238352 BLAKE2B 674c6f29ffdc1413dfc2df407d1a0decbba2a3f65a1be1e8dac3a7b05ed5a6b3599bb4160a5ff09b982f0f698bb408170756c082911fa5e7d3e8b40221e60d2b SHA512 c3c8900326e0bf7e1759379539e476aec43dbe40d3cd3aa476ca50527ec2ba2887eeb6763703a1b1cb4c89a44dda6b7a9cb999246d2a41d7a4b7679b43b5da74
+DIST akonadi-calendar-tools-22.08.2.tar.xz 238304 BLAKE2B 878fcdff9329e8b261dd66296d89b55a75f2e2da7ece29aeedffd7f0c002906c05ca3d028ed7b3904a1d677f247e9612d078ab09110c2aed79142d26d5702e21 SHA512 71e1eb03e655d7cda4e79cb54c9c04f59d137a087da00d0447296b9a257a8a25abc84c0ddeeeb0b89d3185d530a8c34db30badada8cf3586eed3c966d8dea026
diff --git a/kde-apps/konsolekalendar/konsolekalendar-22.08.2.ebuild b/kde-apps/konsolekalendar/konsolekalendar-22.08.2.ebuild
new file mode 100644
index 000000000000..491f6714e5ba
--- /dev/null
+++ b/kde-apps/konsolekalendar/konsolekalendar-22.08.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_HANDBOOK="forceoptional"
+KDE_ORG_NAME="akonadi-calendar-tools"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+inherit ecm gear.kde.org
+
+DESCRIPTION="Command line interface to KDE calendars"
+HOMEPAGE+=" https://userbase.kde.org/KonsoleKalendar"
+
+LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-calendar-${PVCUT}:5
+ >=kde-apps/calendarsupport-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ ecm_src_prepare
+
+ # delete colliding calendarjanitor translations
+ if [[ ${KDE_BUILD_TYPE} = release ]]; then
+ rm -f po/*/calendarjanitor.po || die
+ fi
+
+ cmake_comment_add_subdirectory calendarjanitor
+}