summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 13:48:17 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-02 18:49:59 +0200
commita5eb0cdc3babcccff796ffa393df6e4981959151 (patch)
tree29d28a928a297ed154e2c0308a4e1983df79d4d1 /kde-apps/konsole
parentkde-apps/khelpcenter: drop 21.08.0* (diff)
downloadgentoo-a5eb0cdc3babcccff796ffa393df6e4981959151.tar.gz
gentoo-a5eb0cdc3babcccff796ffa393df6e4981959151.tar.bz2
gentoo-a5eb0cdc3babcccff796ffa393df6e4981959151.zip
kde-apps/konsole: drop 21.08.0*
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/konsole')
-rw-r--r--kde-apps/konsole/Manifest1
-rw-r--r--kde-apps/konsole/files/konsole-21.08.0-fix-KXmlGUI-toolbars-and-MainWindow-size.patch73
-rw-r--r--kde-apps/konsole/files/konsole-21.08.0-fix-MainWindow-size-w-o-saved-size.patch79
-rw-r--r--kde-apps/konsole/files/konsole-21.08.0-fix-crash-w-blur.patch49
-rw-r--r--kde-apps/konsole/konsole-21.08.0-r5.ebuild77
5 files changed, 0 insertions, 279 deletions
diff --git a/kde-apps/konsole/Manifest b/kde-apps/konsole/Manifest
index e94c2617d849..88e098be9c5a 100644
--- a/kde-apps/konsole/Manifest
+++ b/kde-apps/konsole/Manifest
@@ -1,3 +1,2 @@
DIST konsole-21.04.3.tar.xz 1336960 BLAKE2B 2cbcdb3edaae0fec913d82dd0eb2ca80aca70e2b9d749ae1c22512946df8bf5e99aa8444996e41b7bc162727119c8f9216b28b5b15051dd0c6a89221fcbbd355 SHA512 490271a51304d5a64111f6ae74422a6b3143a5349359e55af0845c04a6e6d405fadd1f300dc4d866b7730c0cb852bebfddbb33b0ca9e68d22f264e379d1868e8
-DIST konsole-21.08.0.tar.xz 1373652 BLAKE2B 52661bf8296cb1f64b065f32d0d6a7d4bcf689a45e54c18165b5d4bf6893b7312daa6b45418b9142042154801b34e22388d04998af7d406fed53ab20073dcc11 SHA512 7b59b43e1dd1374001570c7bc611c00c7de738cdf7030954173a8d5b901412cb5653616c12f0b85af38a48e3598bf64d6bce9ca068b520a6683f5fb7bac3c38f
DIST konsole-21.08.1.tar.xz 1374720 BLAKE2B b686def9a04b92b7de71d47fa16f0c1172baf6304dff6b0fcb3ebb11276190b1294ee77bc4245494f874bf39e33f39b5f791d96b8ea6150987ef1fb373b10f47 SHA512 ebac48f71bde793e39fc2f3c0dc39f8fc24e6f9ba8447988ee793ef33154bcbc7f97dfe863b708acc85c472e424c4190625fc8139417f4a98520c4c9a903903d
diff --git a/kde-apps/konsole/files/konsole-21.08.0-fix-KXmlGUI-toolbars-and-MainWindow-size.patch b/kde-apps/konsole/files/konsole-21.08.0-fix-KXmlGUI-toolbars-and-MainWindow-size.patch
deleted file mode 100644
index fc62466ea627..000000000000
--- a/kde-apps/konsole/files/konsole-21.08.0-fix-KXmlGUI-toolbars-and-MainWindow-size.patch
+++ /dev/null
@@ -1,73 +0,0 @@
-From fb7f838fd3138a39aea3bcb2e91f923741587137 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Thu, 29 Jul 2021 18:44:07 +0200
-Subject: [PATCH] Fix KXmlGUI toolbars; and Konsole MainWindow size
-
-Call setupGUI(), which will call createGUI (since we set the
-KXmlGuiWindow::Create flag), omit the StatusBar flag since we don't have a
-statusbar and don't want the "Show StatusBar" menu action.
-
-TabbedViewContainer::sizeHint() calculates an optimum size for itself,
-including the sizes of its child widgets; added in efb621d091c05f11 by
-Mariusz Glebocki; following the code:
-MainWindow creates a ViewManager
-ViewManager creates a TabbedViewContainer and then a TerminalDisplay
-
-which means that the first time TabbedViewContainer::sizeHint() is called
-the TerminalDisplay widget size is 0, then TabbedViewContainer::sizeHint()
-would return 0.
-
-Which is why calling resize() in MainWindow was delayed to the showEvent(),
-(and even delayed more by a QTimer::singleShot() call in Application),
-at which point all the child widgets have been created and
-MainWindow::sizeHint() (which logically takes into account the sizeHint()
-of its child widgets) would return a sensible size.
-
-CCBUG: 430036
-CCBUG: 439339
-BUG: 436471
-
-
-(cherry picked from commit 090356661c92bfedeeeaf6f4f77d294facb3d8c6)
----
- src/MainWindow.cpp | 17 ++++++++++++-----
- 1 file changed, 12 insertions(+), 5 deletions(-)
-
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index c67acf8b9..a4b36b61d 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -131,8 +131,10 @@ MainWindow::MainWindow() :
- // in terminal applications
- KAcceleratorManager::setNoAccel(menuBar());
-
-- // create menus
-- createGUI();
-+ constexpr KXmlGuiWindow::StandardWindowOptions guiOpts = ToolBar | Keys | Save | Create;
-+ const QString xmlFile = componentName() + QLatin1String("ui.rc"); // Typically "konsoleui.rc"
-+ // The "Create" flag will make it call createGUI()
-+ setupGUI(guiOpts, xmlFile);
-
- // remember the original menu accelerators for later use
- rememberMenuAccelerators();
-@@ -945,9 +947,14 @@ void MainWindow::showEvent(QShowEvent *event)
- menuBar()->setVisible(_menuBarInitialVisibility);
- _toggleMenuBarAction->setChecked(_menuBarInitialVisibility);
- _menuBarInitialVisibilityApplied = true;
-- if (!KonsoleSettings::saveGeometryOnExit()) {
-- resize(sizeHint());
-- }
-+ }
-+
-+ if (!KonsoleSettings::saveGeometryOnExit()) {
-+ // Delay resizing to here, so that the other parts of the UI
-+ // (ViewManager, TabbedViewContainer, TerminalDisplay ... etc)
-+ // have been created and TabbedViewContainer::sizeHint() returns
-+ // a usuable size.
-+ resize(sizeHint());
- }
-
- // Call parent method
---
-GitLab
-
diff --git a/kde-apps/konsole/files/konsole-21.08.0-fix-MainWindow-size-w-o-saved-size.patch b/kde-apps/konsole/files/konsole-21.08.0-fix-MainWindow-size-w-o-saved-size.patch
deleted file mode 100644
index 48fe1be666af..000000000000
--- a/kde-apps/konsole/files/konsole-21.08.0-fix-MainWindow-size-w-o-saved-size.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-From c78edfbac49852cec40efd5cbe73c341bc06c5ab Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Thu, 29 Jul 2021 18:45:45 +0200
-Subject: [PATCH] Fix MainWindow size when there is no saved size
-
-The very first time a user runs Konsole, where is no konsolerc file in $HOME,
-there is no saved size to restore, instead use the sizeHint(), which ideally
-will be the size set in the default profile (based on lines/columns setting).
-
-CCBUG: 437791
----
- src/MainWindow.cpp | 21 +++++++++++++++------
- src/MainWindow.h | 1 +
- 2 files changed, 16 insertions(+), 6 deletions(-)
-
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index a4b36b61d..9b025c8fe 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -70,13 +70,22 @@ MainWindow::MainWindow() :
- _menuBarInitialVisibility(true),
- _menuBarInitialVisibilityApplied(false)
- {
-- if (!KonsoleSettings::saveGeometryOnExit()) {
-+ KSharedConfigPtr konsoleConfig = KSharedConfig::openConfig(QStringLiteral("konsolerc"));
-+ KConfigGroup cg = konsoleConfig->group(QStringLiteral("MainWindow"));
-+ const bool isGroup = cg.exists();
-+ if (isGroup) {
-+ const QString stateConfig = cg.readEntry(QStringLiteral("State"));
-+
-+ // If "stateConfig" is empty then this is the very first run,
-+ // i.e. no konsolerc file in $HOME
-+ _isSavedUiState = !stateConfig.isEmpty();
-+ }
-+
-+ if (isGroup && !KonsoleSettings::saveGeometryOnExit()) {
- // If we are not using the global Konsole save geometry on exit,
- // remove all geometry data from [MainWindow] in Konsolerc, so KWin will
- // manage it directly
-- KSharedConfigPtr konsoleConfig = KSharedConfig::openConfig(QStringLiteral("konsolerc"));
-- KConfigGroup group = konsoleConfig->group("MainWindow");
-- QMap<QString, QString> configEntries = group.entryMap();
-+ QMap<QString, QString> configEntries = cg.entryMap();
- QMapIterator<QString, QString> i(configEntries);
-
- while (i.hasNext()) {
-@@ -93,7 +102,7 @@ MainWindow::MainWindow() :
- || i.key().contains(QLatin1String(" YPosition"))
- #endif
- ) {
-- group.deleteEntry(i.key());
-+ cg.deleteEntry(i.key());
- }
- }
- }
-@@ -949,7 +958,7 @@ void MainWindow::showEvent(QShowEvent *event)
- _menuBarInitialVisibilityApplied = true;
- }
-
-- if (!KonsoleSettings::saveGeometryOnExit()) {
-+ if (!_isSavedUiState || !KonsoleSettings::saveGeometryOnExit()) {
- // Delay resizing to here, so that the other parts of the UI
- // (ViewManager, TabbedViewContainer, TerminalDisplay ... etc)
- // have been created and TabbedViewContainer::sizeHint() returns
-diff --git a/src/MainWindow.h b/src/MainWindow.h
-index a80674012..876a81d71 100644
---- a/src/MainWindow.h
-+++ b/src/MainWindow.h
-@@ -200,6 +200,7 @@ private:
- bool _menuBarInitialVisibility;
- bool _menuBarInitialVisibilityApplied;
- bool _blurEnabled = false;
-+ bool _isSavedUiState = false;
- };
- }
-
---
-GitLab
-
diff --git a/kde-apps/konsole/files/konsole-21.08.0-fix-crash-w-blur.patch b/kde-apps/konsole/files/konsole-21.08.0-fix-crash-w-blur.patch
deleted file mode 100644
index b0c7193eda84..000000000000
--- a/kde-apps/konsole/files/konsole-21.08.0-fix-crash-w-blur.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From f24dd6acc28393ba6f731be1360731c01a9a1ef0 Mon Sep 17 00:00:00 2001
-From: Ahmad Samir <a.samirh78@gmail.com>
-Date: Fri, 16 Jul 2021 21:37:51 +0200
-Subject: [PATCH] Fix crash when setting blur effect
-
-Basically to use QWidget::windowHandle() to get a QWindow*, we need to first
-set the Qt::WA_NativeWindow attribute on the QWidget. See:
-https://phabricator.kde.org/D23108
-
-BUG: 439871
-FIXED-IN: 21.12
-(cherry picked from commit a6b2bd539162b39191e827566b656bd97266ffad)
----
- src/MainWindow.cpp | 12 +++++++++++-
- 1 file changed, 11 insertions(+), 1 deletion(-)
-
-diff --git a/src/MainWindow.cpp b/src/MainWindow.cpp
-index ed5d8cc3d..c67acf8b9 100644
---- a/src/MainWindow.cpp
-+++ b/src/MainWindow.cpp
-@@ -56,6 +56,8 @@
- #include "terminalDisplay/TerminalDisplay.h"
- #include "widgets/ViewContainer.h"
-
-+#include <konsoledebug.h>
-+
- using namespace Konsole;
-
- MainWindow::MainWindow() :
-@@ -889,7 +891,15 @@ void MainWindow::setBlur(bool blur)
- #if KWINDOWSYSTEM_VERSION < QT_VERSION_CHECK(5,82,0)
- KWindowEffects::enableBlurBehind(winId(), blur);
- #else
-- KWindowEffects::enableBlurBehind(windowHandle(), blur);
-+ // Set the WA_NativeWindow attribute to force the creation of the QWindow.
-+ // Without this QWidget::windowHandle() returns 0.
-+ // See https://phabricator.kde.org/D23108
-+ setAttribute(Qt::WA_NativeWindow);
-+ if (QWindow *window = windowHandle()) {
-+ KWindowEffects::enableBlurBehind(window, blur);
-+ } else {
-+ qCWarning(KonsoleDebug) << "Blur effect couldn't be enabled.";
-+ }
- #endif
- }
- }
---
-GitLab
-
diff --git a/kde-apps/konsole/konsole-21.08.0-r5.ebuild b/kde-apps/konsole/konsole-21.08.0-r5.ebuild
deleted file mode 100644
index 22a1835a1ffc..000000000000
--- a/kde-apps/konsole/konsole-21.08.0-r5.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-ECM_HANDBOOK="optional"
-ECM_TEST="true"
-KFMIN=5.84.0
-QTMIN=5.15.2
-VIRTUALX_REQUIRED="test"
-inherit ecm kde.org
-
-DESCRIPTION="KDE's terminal emulator"
-HOMEPAGE="https://apps.kde.org/konsole/ https://konsole.kde.org"
-
-LICENSE="GPL-2" # TODO: CHECK
-SLOT="5"
-KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
-IUSE="X"
-
-DEPEND="
- >=dev-qt/qtdbus-${QTMIN}:5
- >=dev-qt/qtgui-${QTMIN}:5
- >=dev-qt/qtnetwork-${QTMIN}:5
- >=dev-qt/qtprintsupport-${QTMIN}:5
- >=dev-qt/qtwidgets-${QTMIN}:5
- >=dev-qt/qtxml-${QTMIN}:5
- >=kde-frameworks/kbookmarks-${KFMIN}:5
- >=kde-frameworks/kconfig-${KFMIN}:5
- >=kde-frameworks/kconfigwidgets-${KFMIN}:5
- >=kde-frameworks/kcoreaddons-${KFMIN}:5
- >=kde-frameworks/kcrash-${KFMIN}:5
- >=kde-frameworks/kdbusaddons-${KFMIN}:5
- >=kde-frameworks/kguiaddons-${KFMIN}:5
- >=kde-frameworks/kjobwidgets-${KFMIN}:5
- >=kde-frameworks/ki18n-${KFMIN}:5
- >=kde-frameworks/kiconthemes-${KFMIN}:5
- >=kde-frameworks/kio-${KFMIN}:5
- >=kde-frameworks/knewstuff-${KFMIN}:5
- >=kde-frameworks/knotifications-${KFMIN}:5
- >=kde-frameworks/knotifyconfig-${KFMIN}:5
- >=kde-frameworks/kparts-${KFMIN}:5
- >=kde-frameworks/kpty-${KFMIN}:5
- >=kde-frameworks/kservice-${KFMIN}:5
- >=kde-frameworks/ktextwidgets-${KFMIN}:5
- >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
- >=kde-frameworks/kwindowsystem-${KFMIN}:5
- >=kde-frameworks/kxmlgui-${KFMIN}:5
- X? ( x11-libs/libX11 )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-21.04.3-no-flash-on-session-close.patch" # bug 807933
- "${FILESDIR}/${PN}-21.04.3-dont-close-window-while-split.patch" # bug 808510
- "${FILESDIR}/${PN}-21.04.3-emit-empty-in-SessionFinished-only-in-TabbedNavigation-mode.patch" # bug 810598
- "${FILESDIR}/${P}-fix-crash-w-blur.patch" # bug 807905, fixed in 21.08.1
- "${FILESDIR}/${P}-fix-KXmlGUI-toolbars-and-MainWindow-size.patch" # KDE-bugs 430036, 439339
- "${FILESDIR}/${P}-fix-MainWindow-size-w-o-saved-size.patch" # KDE-bug 437791
-)
-
-src_configure() {
- local mycmakeargs=(
- $(cmake_use_find_package X X11)
- )
-
- ecm_src_configure
-}
-
-src_test() {
- # drkonqi process interferes. bug 702690
- local myctestargs=(
- -E "(DBusTest)"
- )
-
- ecm_src_test
-}