summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-08-20 22:57:58 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-08-20 22:59:20 +0100
commit2eea51ea01574d445cf1f8b3fb84b8d5f10d66fd (patch)
tree22a5fd9c3664ea540d49489786bee3e8f39104ea /gui-wm
parentgui-wm/gamescope: add x11-libs/libXmu to RDEPEND (diff)
downloadgentoo-2eea51ea01574d445cf1f8b3fb84b8d5f10d66fd.tar.gz
gentoo-2eea51ea01574d445cf1f8b3fb84b8d5f10d66fd.tar.bz2
gentoo-2eea51ea01574d445cf1f8b3fb84b8d5f10d66fd.zip
gui-wm/gamescope: Bump to 3.12.3, drop old 3.11.51 + 3.12.0
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/gamescope/Manifest3
-rw-r--r--gui-wm/gamescope/gamescope-3.11.51.ebuild79
-rw-r--r--gui-wm/gamescope/gamescope-3.12.3.ebuild (renamed from gui-wm/gamescope/gamescope-3.12.0.ebuild)0
3 files changed, 1 insertions, 81 deletions
diff --git a/gui-wm/gamescope/Manifest b/gui-wm/gamescope/Manifest
index 0ab50cacbe8b..c8cb4c0e69b9 100644
--- a/gui-wm/gamescope/Manifest
+++ b/gui-wm/gamescope/Manifest
@@ -1,2 +1 @@
-DIST gamescope-3.11.51.tar.gz 209920 BLAKE2B fdccd6659e33a9ae43eaabc5d41cfa6d0a92bda1a283e23f101296713f5094093b7b41135de44abd65ff17c66d70b27baf50685dcd2a47084022fb611e150a5b SHA512 a4ddd96a4fdacd62eee800f6fb331d08fca32c2798d64148529181a0ee8d8af57d5d67bfa28bff8e9cf62047a7572c43b36e2968660ea2984b8e21fa812baf9e
-DIST gamescope-3.12.0.tar.gz 437848 BLAKE2B 4bf54969557af6a03e6cf788b0e02a4a2dd3981a69abaccfd6b0709003134d984b098dfc2a102041a4d34149423c37ca77efc9947cc2801979a488fea5a44db0 SHA512 864d61d9caf0bb8b13c71a084dd54a74e4d9104168cdc9ff8bc971e5a78a019fa80bf43c3b58b2e5ade6d461842385c37c3184ceede7e058d4d8d989a9e62bd9
+DIST gamescope-3.12.3.tar.gz 439564 BLAKE2B aaa0d2c1a8149bea29a794e4738f1ca24c5d2a8e0a764195e95dd38ac36547ad9790765397e7ba1f81cc33d613507a9a9da4910116f6258f1390133d2f6549fc SHA512 9f78467bb8fe34eb731d645c452442a4db4ba6fa8cf8055d0a0b6e6f4e74ef281a4b6fee5f1555a147d554a0a6579d9f9aac4b613b0b2de267f04584593455c9
diff --git a/gui-wm/gamescope/gamescope-3.11.51.ebuild b/gui-wm/gamescope/gamescope-3.11.51.ebuild
deleted file mode 100644
index c46661baaf0c..000000000000
--- a/gui-wm/gamescope/gamescope-3.11.51.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit fcaps meson
-
-MY_PV=$(ver_rs 3 -)
-MY_PV="${MY_PV//_/-}"
-DESCRIPTION="Efficient micro-compositor for running games"
-HOMEPAGE="https://github.com/ValveSoftware/gamescope"
-SRC_URI="https://github.com/ValveSoftware/${PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-LICENSE="BSD-2"
-SLOT="0"
-IUSE="pipewire"
-
-RDEPEND="
- =dev-libs/libliftoff-0.3*
- >=dev-libs/wayland-1.21
- >=dev-libs/wayland-protocols-1.17
- =gui-libs/wlroots-0.16*[X]
- media-libs/libsdl2[video,vulkan]
- media-libs/vulkan-loader
- sys-apps/hwdata
- sys-libs/libcap
- >=x11-libs/libdrm-2.4.109
- x11-libs/libX11
- x11-libs/libxcb
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXext
- x11-libs/libXfixes
- x11-libs/libxkbcommon
- x11-libs/libXmu
- x11-libs/libXrender
- x11-libs/libXres
- x11-libs/libXtst
- x11-libs/libXxf86vm
- pipewire? ( >=media-video/pipewire-0.3:= )
-"
-DEPEND="
- ${RDEPEND}
- dev-libs/stb
- dev-util/vulkan-headers
- ~media-libs/vkroots-0_p20221205
-"
-BDEPEND="
- dev-util/glslang
- dev-util/wayland-scanner
-"
-
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-FILECAPS=(
- cap_sys_nice usr/bin/${PN}
-)
-
-src_prepare() {
- default
-
- # Normally uses stb from a git submodule. Upstream does not ship a
- # pkg-config file so we don't install one. Work around this using symlinks.
- mkdir subprojects/stb || die
- ln -sn "${ESYSROOT}"/usr/include/stb/* "${S}"/subprojects/packagefiles/stb/* subprojects/stb/ || die
-
- # Normally uses vkroots from a git submodule. Upstream ships a Meson file
- # that is sourced by this project. Create a symlink to it.
- rm -r subprojects/vkroots || die
- ln -sn "${ESYSROOT}"/usr/include/vkroots subprojects/ || die
-}
-
-src_configure() {
- local emesonargs=(
- --force-fallback-for=
- $(meson_feature pipewire)
- )
- meson_src_configure
-}
diff --git a/gui-wm/gamescope/gamescope-3.12.0.ebuild b/gui-wm/gamescope/gamescope-3.12.3.ebuild
index 8de18f8b6b60..8de18f8b6b60 100644
--- a/gui-wm/gamescope/gamescope-3.12.0.ebuild
+++ b/gui-wm/gamescope/gamescope-3.12.3.ebuild