summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-06-02 04:05:24 +0100
committerSam James <sam@gentoo.org>2024-06-02 04:05:24 +0100
commit8e0c34cdb7c4343788910a3cc672a37db94ff66a (patch)
tree2bca8b654a5279958de3ebb86bb2ff98c8809e44 /gui-apps
parentapp-misc/grc: enable py3.12 (diff)
downloadgentoo-8e0c34cdb7c4343788910a3cc672a37db94ff66a.tar.gz
gentoo-8e0c34cdb7c4343788910a3cc672a37db94ff66a.tar.bz2
gentoo-8e0c34cdb7c4343788910a3cc672a37db94ff66a.zip
gui-apps/waypipe: drop 0.8.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waypipe/Manifest1
-rw-r--r--gui-apps/waypipe/waypipe-0.8.6.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/gui-apps/waypipe/Manifest b/gui-apps/waypipe/Manifest
index 1a2196d694c6..e526a228f598 100644
--- a/gui-apps/waypipe/Manifest
+++ b/gui-apps/waypipe/Manifest
@@ -1,2 +1 @@
-DIST waypipe-v0.8.6.tar.bz2 189836 BLAKE2B 4023ddb325982d5cb189bafb9c4bf87f1ccd692c423371b05d273ab2d8ceeeacace256400e5755e89670407746f25ff4499643d3fb722053e5958547ac15600f SHA512 d02afa15e363009820e7e7ad75e8f294a58b42ec74f8a2cd310fc3c65a252b71524a89fb95e3e105cec8d6802fb30470c6842ae69d7c16d687edde96d4ff1263
DIST waypipe-v0.9.0.tar.bz2 193493 BLAKE2B 891b1015951459faf15c181c35499558458fd69c63695f4b6be67e686c8ba7806f0193ed0fc4500b370345b570536b6fdbb3c01f2fe861e87e00b1d4db7c05d7 SHA512 c37b630f4659ccc52d2a85a749971d552d5d535fc33e30aea1c2d22b057aaf3cf2756d6347cc89e3068ce59a14e871e7ffae9016608803549d0e7b1b6a0bd1cf
diff --git a/gui-apps/waypipe/waypipe-0.8.6.ebuild b/gui-apps/waypipe/waypipe-0.8.6.ebuild
deleted file mode 100644
index 973c438e2f8b..000000000000
--- a/gui-apps/waypipe/waypipe-0.8.6.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-inherit meson python-any-r1
-
-DESCRIPTION="Transparent network proxy for Wayland compositors"
-HOMEPAGE="https://gitlab.freedesktop.org/mstoeckl/waypipe"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.freedesktop.org/mstoeckl/waypipe"
-else
- SRC_URI="https://gitlab.freedesktop.org/mstoeckl/waypipe/-/archive/v${PV}/${PN}-v${PV}.tar.bz2"
- S="${WORKDIR}"/${PN}-v${PV}
- KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-WAYPIPE_FLAG_MAP_X86=( avx2:with_avx2 avx512f:with_avx512f sse3:with_sse3 )
-WAYPIPE_FLAG_MAP_ARM=( neon:with_neon_opts )
-WAYPIPE_FLAG_MAP=(
- "${WAYPIPE_FLAG_MAP_X86[@]/#/cpu_flags_x86_}"
- "${WAYPIPE_FLAG_MAP_ARM[@]/#/cpu_flags_arm_}"
-)
-
-IUSE="dmabuf ffmpeg lz4 systemtap test vaapi zstd ${WAYPIPE_FLAG_MAP[@]%:*}"
-REQUIRED_USE="vaapi? ( ffmpeg )"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dmabuf? (
- media-libs/mesa[gbm(+),vaapi?,wayland]
- x11-libs/libdrm
- )
- lz4? ( app-arch/lz4 )
- systemtap? ( dev-debug/systemtap )
- vaapi? ( media-libs/libva[drm(+),wayland] )
- ffmpeg? (
- media-video/ffmpeg[x264,vaapi?]
- )
- zstd? ( app-arch/zstd )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- ${PYTHON_DEPS}
- app-text/scdoc
- virtual/pkgconfig
- test? ( dev-libs/weston[examples,headless,remoting,screen-sharing,wayland-compositor] )
-"
-
-src_configure() {
- local emesonargs=(
- -Dman-pages=enabled
- $(meson_use systemtap with_systemtap)
- $(meson_feature dmabuf with_dmabuf)
- $(meson_feature ffmpeg with_video)
- $(meson_feature lz4 with_lz4)
- $(meson_feature vaapi with_vaapi)
- $(meson_feature zstd with_zstd)
- )
- local fl
- for fl in "${WAYPIPE_FLAG_MAP[@]}"; do
- emesonargs+=( $(meson_use "${fl%:*}" "${fl#*:}") )
- done
- meson_src_configure
-}