summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-22 11:37:36 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-25 11:25:04 -0400
commit2854b535bf5ef6b77d97e46be820187e14f03424 (patch)
tree6661d828c3403597069e9ed0eb770ec86504bfad /gnome-extra/gucharmap
parentmedia-gfx/eog: Version bump to 43.1 (diff)
downloadgentoo-2854b535bf5ef6b77d97e46be820187e14f03424.tar.gz
gentoo-2854b535bf5ef6b77d97e46be820187e14f03424.tar.bz2
gentoo-2854b535bf5ef6b77d97e46be820187e14f03424.zip
gnome-extra/gucharmap: Version bump to 15.0.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/27902 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/files/15.0.1-fix-file-conflicts.patch11
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.0.1.ebuild74
3 files changed, 86 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 8f7c708ab961..fc94c6ffcb09 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1,3 +1,4 @@
DIST gucharmap-14.0.3.tar.gz 1931686 BLAKE2B e72b46450ad97a49519014882cbfd5792a07daf782fdf0d80e4b9221537548a57d3b43dc2b421f3f72d3b0adfee6f11c53304b4468c78b766ffee9536efebba2 SHA512 cb43265a2b54231c15331c299ed10bba8bb83bdc1860ee50764bed8a40ce1421f49edfeb7fa5814c8aac6c23f80936a966346849db83ddf7f94a370adeffc6c8
DIST gucharmap-15.0.0.tar.gz 1936653 BLAKE2B 4ff592bca75a08e19921c2b08c19ea2693b4652986f2cf77536cf3e056353cf9bfe44e66e15b402552f5ab1b97631f53e07ac10b530164b0ba1d479f70d2b4c2 SHA512 b72f4bf5b6b4d922c91bd1fb58070a5bcdc4364f96144db7446c8a94045158bc3c9e549f1bd3db3f27bb22e6b83a130c73cbd7c737c49a2bb0e2a6a5c8756a66
+DIST gucharmap-15.0.1.tar.gz 1938073 BLAKE2B 0a6b6e76bb60648c591354394d2dfb78f56508dbf7d0b62edb945b8e79b6cbe7f333e7245d374fae9476986e06aee99bca53fe05da6a2e66629e33941fa79bd5 SHA512 77a6cd6bfa4465140a1014c8b1a9783acf6feb656925f319627f3fe5a0e091fa1819d82e3f5ca4f9eaa0c6e6bf8ace66ae6895360b9574a8f9ac7a347c37e103
DIST gucharmap-3.0.1.tar.bz2 3275481 BLAKE2B 80dde7791abdc72677add9c65c59f810e6c6952116b92db34059c4c40d2657246b17844c105e68f32c86294e9b4e71e9d48e6f0522855465734d7c24e8d17608 SHA512 4d8a2276b5cb1a0b0fadca2a8522755c5884985a12d5b19341b9cefcd7f749ec1286c0271419e38ec84be7edcfa1293e7f0263eb682c75387d692792de3e1fb1
diff --git a/gnome-extra/gucharmap/files/15.0.1-fix-file-conflicts.patch b/gnome-extra/gucharmap/files/15.0.1-fix-file-conflicts.patch
new file mode 100644
index 000000000000..0664c9f0c546
--- /dev/null
+++ b/gnome-extra/gucharmap/files/15.0.1-fix-file-conflicts.patch
@@ -0,0 +1,11 @@
+Avoids file conficts with other API versions being installed on the system.
+--- a/meson.build
++++ b/meson.build
+@@ -78,6 +78,6 @@ libgucharmap_gtk4_soversion = '0'
+
+ # i18n
+
+-gucharmap_gettext_domain = gucharmap_name
++gucharmap_gettext_domain = libgucharmap_gtk3_api_name
+
+ # Directories
diff --git a/gnome-extra/gucharmap/gucharmap-15.0.1.ebuild b/gnome-extra/gucharmap/gucharmap-15.0.1.ebuild
new file mode 100644
index 000000000000..6308b8aae15b
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-15.0.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap https://gitlab.gnome.org/GNOME/gucharmap/"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="15.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+ "${FILESDIR}"/15.0.1-fix-file-conflicts.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}