summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/gnome-extra-apps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/gnome-extra-apps')
-rw-r--r--gnome-base/gnome-extra-apps/gnome-extra-apps-3.14.0-r1.ebuild74
-rw-r--r--gnome-base/gnome-extra-apps/gnome-extra-apps-3.16.0.ebuild76
-rw-r--r--gnome-base/gnome-extra-apps/metadata.xml11
3 files changed, 161 insertions, 0 deletions
diff --git a/gnome-base/gnome-extra-apps/gnome-extra-apps-3.14.0-r1.ebuild b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.14.0-r1.ebuild
new file mode 100644
index 000000000000..bc56c1727e2e
--- /dev/null
+++ b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.14.0-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the applications of GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+games +share +shotwell +tracker"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="amd64 x86"
+
+# Note to developers:
+# This is a wrapper for the extra apps integrated with GNOME 3
+# New package
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}
+
+ >=app-admin/gnome-system-log-3.9.90
+ >=app-arch/file-roller-${PV}
+ >=app-dicts/gnome-dictionary-${PV}
+ >=gnome-extra/gconf-editor-3
+ >=gnome-extra/gnome-calculator-${PV}
+ >=gnome-extra/gnome-power-manager-${PV}
+ >=gnome-extra/gnome-search-tool-3.6
+ >=gnome-extra/gnome-system-monitor-${PV}
+ >=gnome-extra/gnome-tweak-tool-${PV}
+ >=gnome-extra/gnome-weather-${PV}
+ >=gnome-extra/gucharmap-${PV}:2.90
+ >=gnome-extra/nautilus-sendto-3.8.2
+ >=gnome-extra/sushi-3.12.0
+ >=mail-client/evolution-3.12.9
+ >=media-gfx/gnome-font-viewer-${PV}
+ >=media-gfx/gnome-screenshot-${PV}
+ >=media-sound/sound-juicer-${PV}
+ >=media-video/cheese-${PV}
+ >=net-analyzer/gnome-nettool-3.8
+ >=net-misc/vinagre-${PV}
+ >=net-misc/vino-${PV}
+ >=sys-apps/baobab-${PV}
+ >=sys-apps/gnome-disk-utility-${PV}
+ >=www-client/epiphany-3.12
+
+ games? (
+ >=games-arcade/gnome-nibbles-${PV}
+ >=games-arcade/gnome-robots-${PV}
+ >=games-board/four-in-a-row-${PV}
+ >=games-board/gnome-chess-${PV}
+ >=games-board/gnome-mahjongg-${PV}
+ >=games-board/gnome-mines-${PV}
+ >=games-board/iagno-${PV}
+ >=games-board/tali-${PV}
+ >=games-puzzle/five-or-more-${PV}
+ >=games-puzzle/gnome-klotski-${PV}
+ >=games-puzzle/gnome-sudoku-${PV}
+ >=games-puzzle/gnome-tetravex-${PV}
+ >=games-puzzle/hitori-${PV}
+ >=games-puzzle/lightsoff-${PV}
+ >=games-puzzle/quadrapassel-${PV}
+ >=games-puzzle/swell-foop-${PV} )
+ share? ( >=gnome-extra/gnome-user-share-${PV} )
+ shotwell? ( >=media-gfx/shotwell-0.20 )
+ tracker? (
+ >=app-misc/tracker-1.2
+ >=gnome-extra/gnome-documents-${PV}
+ >=media-gfx/gnome-photos-${PV}
+ >=media-sound/gnome-music-${PV} )
+"
+DEPEND=""
+S=${WORKDIR}
diff --git a/gnome-base/gnome-extra-apps/gnome-extra-apps-3.16.0.ebuild b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.16.0.ebuild
new file mode 100644
index 000000000000..0064db2ca2ea
--- /dev/null
+++ b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.16.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the applications of GNOME 3"
+HOMEPAGE="http://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+games +share +shotwell +tracker"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# Note to developers:
+# This is a wrapper for the extra apps integrated with GNOME 3
+# New package
+RDEPEND="
+ >=gnome-base/gnome-core-libs-${PV}
+
+ >=app-admin/gnome-system-log-3.9.90
+ >=app-arch/file-roller-${PV}
+ >=app-dicts/gnome-dictionary-${PV}
+ >=gnome-base/dconf-editor-${PV}
+ >=gnome-extra/gconf-editor-3
+ >=gnome-extra/gnome-calculator-${PV}
+ >=gnome-extra/gnome-power-manager-${PV}
+ >=gnome-extra/gnome-search-tool-3.6
+ >=gnome-extra/gnome-system-monitor-${PV}
+ >=gnome-extra/gnome-tweak-tool-${PV}
+ >=gnome-extra/gnome-weather-${PV}
+ >=gnome-extra/gucharmap-${PV}:2.90
+ >=gnome-extra/nautilus-sendto-3.8.2
+ >=gnome-extra/sushi-${PV}
+ >=mail-client/evolution-3.16
+ >=media-gfx/gnome-font-viewer-${PV}
+ >=media-gfx/gnome-screenshot-${PV}
+ >=media-sound/sound-juicer-${PV}
+ >=media-video/cheese-${PV}
+ >=net-analyzer/gnome-nettool-3.8
+ >=net-misc/vinagre-${PV}
+ >=net-misc/vino-${PV}
+ >=sys-apps/baobab-${PV}
+ >=sys-apps/gnome-disk-utility-${PV}
+ >=www-client/epiphany-${PV}
+
+ games? (
+ >=games-arcade/gnome-nibbles-${PV}
+ >=games-arcade/gnome-robots-${PV}
+ >=games-board/four-in-a-row-${PV}
+ >=games-board/gnome-chess-${PV}
+ >=games-board/gnome-mahjongg-${PV}
+ >=games-board/gnome-mines-${PV}
+ >=games-board/iagno-${PV}
+ >=games-board/tali-${PV}
+ >=games-puzzle/five-or-more-${PV}
+ >=games-puzzle/gnome-klotski-${PV}
+ >=games-puzzle/gnome-sudoku-${PV}
+ >=games-puzzle/gnome-taquin-${PV}
+ >=games-puzzle/gnome-tetravex-${PV}
+ >=games-puzzle/hitori-${PV}
+ >=games-puzzle/lightsoff-${PV}
+ >=games-puzzle/quadrapassel-${PV}
+ >=games-puzzle/swell-foop-${PV} )
+ share? ( >=gnome-extra/gnome-user-share-3.14 )
+ shotwell? ( >=media-gfx/shotwell-0.22 )
+ tracker? (
+ >=app-misc/tracker-1.4
+ >=gnome-extra/gnome-documents-${PV}
+ >=media-gfx/gnome-photos-${PV}
+ >=media-sound/gnome-music-${PV} )
+"
+DEPEND=""
+S=${WORKDIR}
diff --git a/gnome-base/gnome-extra-apps/metadata.xml b/gnome-base/gnome-extra-apps/metadata.xml
new file mode 100644
index 000000000000..502f705dcf13
--- /dev/null
+++ b/gnome-base/gnome-extra-apps/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="games">Install Gnome Games</flag>
+ <flag name="share">Install the <pkg>gnome-extra/gnome-user-share</pkg> personal file sharing tool</flag>
+ <flag name="shotwell">Install the <pkg>media-gfx/shotwell</pkg> photo manager</flag>
+ <flag name="tracker">Install the <pkg>app-misc/tracker</pkg> indexer and the GNOME packages that require it</flag>
+</use>
+</pkgmetadata>