summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/atlas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/atlas')
-rw-r--r--games-util/atlas/Manifest1
-rw-r--r--games-util/atlas/atlas-0.4.9_p20140320.ebuild82
-rw-r--r--games-util/atlas/metadata.xml9
3 files changed, 92 insertions, 0 deletions
diff --git a/games-util/atlas/Manifest b/games-util/atlas/Manifest
new file mode 100644
index 000000000000..3851f7d96613
--- /dev/null
+++ b/games-util/atlas/Manifest
@@ -0,0 +1 @@
+DIST Atlas-0.4.9_cvs20140320.tar.bz2 387926 SHA256 8b43307e5e570c8051219a2deec0845b2df02f975a58ca06cc9ed77672acf5ff SHA512 c43b80aed945dc2ba7cd6d9cc95a3691f6583cc2a615d5c7d018575306b10fb99fc5a115691b9f31c43cbe91bf53b101bd4a1cde0747e614a99dc3a49268d70b WHIRLPOOL ffb93d372cf7186c9522bccbe5f462d0b94a11c8f01723b6e4a038a6cf80a00d9178c311c6294d6fe00291b6084200ed9d5407a0c6c744661a1447a9021eeaa2
diff --git a/games-util/atlas/atlas-0.4.9_p20140320.ebuild b/games-util/atlas/atlas-0.4.9_p20140320.ebuild
new file mode 100644
index 000000000000..36701f02a75f
--- /dev/null
+++ b/games-util/atlas/atlas-0.4.9_p20140320.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils games
+
+MY_PN=Atlas
+MY_PV=${PV/p/cvs}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="Chart Program to use with Flightgear Flight Simulator"
+HOMEPAGE="http://atlas.sourceforge.net/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/freeglut
+ >=media-libs/libpng-1.5
+ net-misc/curl
+ sys-libs/zlib
+ virtual/glu
+ virtual/jpeg
+ virtual/opengl
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-games/simgear-3.0.0
+ media-libs/plib
+"
+RDEPEND="${COMMON_DEPEND}
+ >=games-simulation/flightgear-3.0.0
+"
+
+S=${WORKDIR}/${MY_PN}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --enable-simgear-shared \
+ --with-fgbase="${GAMES_DATADIR}"/flightgear
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas
+ doins src/data/*.{jpg,png} || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas/Palettes
+ doins src/data/Palettes/*.ap || die
+ insinto "${GAMES_DATADIR}"/flightgear/Atlas/Fonts
+ doins src/data/Fonts/*.txf || die
+ dodoc AUTHORS NEWS README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You now can make the maps with the following commands:"
+ elog "${GAMES_BINDIR}/Map --atlas=${GAMES_DATADIR}/flightgear/Atlas"
+ elog
+ elog "To run Atlas concurrently with FlightGear use the following:"
+ elog "Atlas --path=[path of map images] --udp=[port number]"
+ elog "and start fgfs with the following switch (or in .fgfsrc):"
+ elog "--nmea=socket,out,0.5,[host that you run Atlas on],[port number],udp"
+ echo
+}
+
+pkg_postrm() {
+ elog "You must manually remove the maps if you don't want them around."
+ elog "They are found in the following directory:"
+ echo
+ elog "${GAMES_DATADIR}/flightgear/Atlas"
+ echo
+}
diff --git a/games-util/atlas/metadata.xml b/games-util/atlas/metadata.xml
new file mode 100644
index 000000000000..bf9480ea717d
--- /dev/null
+++ b/games-util/atlas/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>reavertm@gentoo.org</email>
+ <name>Maciej Mrozowski</name>
+</maintainer>
+</pkgmetadata>