summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-27 22:51:27 +0100
committerSam James <sam@gentoo.org>2022-09-27 22:51:27 +0100
commitce74c55992aec2610226e83a99eb8b56ce3ca32c (patch)
treeb8b3d675430ff07caddd6e7eaf05ec2c65953445 /games-misc
parentsys-kernel/dracut: homepage moved (diff)
downloadgentoo-ce74c55992aec2610226e83a99eb8b56ce3ca32c.tar.gz
gentoo-ce74c55992aec2610226e83a99eb8b56ce3ca32c.tar.bz2
gentoo-ce74c55992aec2610226e83a99eb8b56ce3ca32c.zip
games-misc/sex: fix implicit function decls
Closes: https://bugs.gentoo.org/871414 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/sex/files/sex-1.0-Add-missing-string.h-for-strcmp.patch15
-rw-r--r--games-misc/sex/sex-1.0-r3.ebuild (renamed from games-misc/sex/sex-1.0-r2.ebuild)9
2 files changed, 22 insertions, 2 deletions
diff --git a/games-misc/sex/files/sex-1.0-Add-missing-string.h-for-strcmp.patch b/games-misc/sex/files/sex-1.0-Add-missing-string.h-for-strcmp.patch
new file mode 100644
index 000000000000..19070d43815b
--- /dev/null
+++ b/games-misc/sex/files/sex-1.0-Add-missing-string.h-for-strcmp.patch
@@ -0,0 +1,15 @@
+From: Sam James <sam@gentoo.org>
+Date: Tue, 27 Sep 2022 22:50:12 +0100
+Subject: [PATCH] Add missing <string.h> for strcmp
+
+Bug: https://bugs.gentoo.org/871414
+--- a/sex.c
++++ b/sex.c
+@@ -10,6 +10,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <time.h>
+ #include <ctype.h>
+
diff --git a/games-misc/sex/sex-1.0-r2.ebuild b/games-misc/sex/sex-1.0-r3.ebuild
index d76e5fcc9923..fddaf87ed5f3 100644
--- a/games-misc/sex/sex-1.0-r2.ebuild
+++ b/games-misc/sex/sex-1.0-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,9 +15,14 @@ KEYWORDS="~alpha ~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="!sci-astronomy/sextractor"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-Add-missing-string.h-for-strcmp.patch
+)
+
src_prepare() {
default
- rm -f Makefile
+
+ rm -f Makefile || die
}
src_compile() {