summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-misc/wtf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-misc/wtf')
-rw-r--r--games-misc/wtf/Manifest1
-rw-r--r--games-misc/wtf/files/wtf-20090924-prefix.patch11
-rw-r--r--games-misc/wtf/metadata.xml5
-rw-r--r--games-misc/wtf/wtf-20090924.ebuild35
4 files changed, 52 insertions, 0 deletions
diff --git a/games-misc/wtf/Manifest b/games-misc/wtf/Manifest
new file mode 100644
index 000000000000..f03e9825fc06
--- /dev/null
+++ b/games-misc/wtf/Manifest
@@ -0,0 +1 @@
+DIST wtf-20090924.tar.bz2 9888 SHA256 2da6ed16657d78e6bd58855803de4e1b7cb2467196b2897781529c19df5d5b23 SHA512 85a7b5b7add12f775272851095f86efa2962875aa9008aec5079d3aec31a74a2d475d5c904013134b4045872fb8e301e95f3c5fa25ab8872a7d31012653bddb0 WHIRLPOOL be5647823d7d88fed827dc44d9107b20f3b3bfed4d8972b567d74b8cf01a81a47bb2e4ae3d28a22f008f466b5b764a2a5fec12b2b777b285b683d1661a8cff21
diff --git a/games-misc/wtf/files/wtf-20090924-prefix.patch b/games-misc/wtf/files/wtf-20090924-prefix.patch
new file mode 100644
index 000000000000..87dc6436e086
--- /dev/null
+++ b/games-misc/wtf/files/wtf-20090924-prefix.patch
@@ -0,0 +1,11 @@
+--- wtf.orig 2009-09-27 10:46:12 +0200
++++ wtf 2009-09-27 10:46:57 +0200
+@@ -12,7 +12,7 @@
+ exit 1
+ }
+
+-acronyms=${ACRONYMDB:-`ls /usr/share/misc/acronyms* 2>/dev/null`}
++acronyms=${ACRONYMDB:-`ls "@GENTOO_PORTAGE_EPREFIX@"/usr/share/misc/acronyms* 2>/dev/null`}
+
+ if [ "$acronyms" = "" ]; then
+ echo "$PROGNAME: acronyms database not found!" >&2
diff --git a/games-misc/wtf/metadata.xml b/games-misc/wtf/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-misc/wtf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-misc/wtf/wtf-20090924.ebuild b/games-misc/wtf/wtf-20090924.ebuild
new file mode 100644
index 000000000000..52bec1e45130
--- /dev/null
+++ b/games-misc/wtf/wtf-20090924.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils prefix
+
+DESCRIPTION="translates acronyms for you"
+HOMEPAGE="http://netbsd.org/"
+SRC_URI="http://dev.gentooexperimental.org/~darkside/distfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="!games-misc/bsd-games"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-prefix.patch
+ eprefixify wtf
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin wtf
+ doman wtf.6
+ insinto /usr/share/misc
+ doins acronyms*
+ dodoc README
+}