summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-kids/crayon-physics
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-kids/crayon-physics')
-rw-r--r--games-kids/crayon-physics/Manifest1
-rw-r--r--games-kids/crayon-physics/crayon-physics-55.ebuild86
-rw-r--r--games-kids/crayon-physics/metadata.xml11
3 files changed, 98 insertions, 0 deletions
diff --git a/games-kids/crayon-physics/Manifest b/games-kids/crayon-physics/Manifest
new file mode 100644
index 000000000000..c84d9520f0dd
--- /dev/null
+++ b/games-kids/crayon-physics/Manifest
@@ -0,0 +1 @@
+DIST crayon_physics_deluxe-linux-release55.tar.gz 33236439 SHA256 1a8f29fc298abea8fdde2b926d33e00e88500f2a8eef5d78c97355b5483d4a8b SHA512 1840cabba5b922f155b90c4442c460e7dc5c63aa2e1348a5f175211d5264c645c08af9a3bd43861aa8497e111678a7314b94d2ba0035b2e07e811200f1af07eb WHIRLPOOL 4413692ea91a09f0e87c56e2eb030e2e5874a3994579bd744bc0c3d10a2919db1780ff16d0073ae9fc56f1fc8bed264b947f02396c306d7f70b497b19da1ac9e
diff --git a/games-kids/crayon-physics/crayon-physics-55.ebuild b/games-kids/crayon-physics/crayon-physics-55.ebuild
new file mode 100644
index 000000000000..0bf114e83f3b
--- /dev/null
+++ b/games-kids/crayon-physics/crayon-physics-55.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils gnome2-utils games
+
+DESCRIPTION="2D physics puzzle/sandbox game with drawing"
+HOMEPAGE="http://www.crayonphysics.com/"
+SRC_URI="crayon_physics_deluxe-linux-release${PV}.tar.gz"
+
+LICENSE="CRAYON-PHYSICS"
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+IUSE="bundled-libs"
+RESTRICT="bindist fetch splitdebug"
+
+MYGAMEDIR=${GAMES_PREFIX_OPT}/${PN}
+QA_PREBUILT="${MYGAMEDIR#/}/crayon
+ ${MYGAMEDIR#/}/lib32/*"
+
+# fuck this pulseaudio linkage
+RDEPEND="
+ media-sound/pulseaudio[abi_x86_32(-)]
+ dev-qt/qtcore:4[abi_x86_32(-)]
+ dev-qt/qtgui:4[abi_x86_32(-)]
+ virtual/glu[abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x86? (
+ !bundled-libs? (
+ media-libs/libmikmod
+ media-libs/libsdl:0[X,sound,video,opengl,joystick]
+ media-libs/libvorbis
+ media-libs/sdl-image[png,jpeg,tiff]
+ media-libs/sdl-mixer[vorbis,wav]
+ media-libs/smpeg[X,opengl]
+ media-libs/tiff:0
+ virtual/jpeg
+ )
+ )"
+
+S=${WORKDIR}/CrayonPhysicsDeluxe
+
+pkg_nofetch() {
+ einfo "Please buy & download ${SRC_URI} from:"
+ einfo " ${HOMEPAGE}"
+ einfo "and move it to ${DISTDIR}"
+ einfo
+}
+
+src_prepare() {
+ if use bundled-libs ; then
+ mv lib32/_libSDL-1.2.so.0 lib32/libSDL-1.2.so.0 || die
+ fi
+}
+
+src_install() {
+ insinto "${MYGAMEDIR}"
+ use bundled-libs && doins -r lib32
+ doins -r cache data crayon autoexec.txt version.xml
+
+ newicon -s 256 icon.png ${PN}.png
+ make_desktop_entry ${PN}
+ games_make_wrapper ${PN} "./crayon" "${MYGAMEDIR}" "${MYGAMEDIR}/lib32"
+
+ dodoc changelog.txt linux_hotfix_notes.txt
+ dohtml readme.html
+
+ fperms +x "${MYGAMEDIR}"/crayon
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-kids/crayon-physics/metadata.xml b/games-kids/crayon-physics/metadata.xml
new file mode 100644
index 000000000000..d13413d31d91
--- /dev/null
+++ b/games-kids/crayon-physics/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name='bundled-libs'>
+ Use the upstream provided bundled libraries.
+ </flag>
+ </use>
+</pkgmetadata>
+