summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Sokolov <alexey+gentoo@asokolov.org>2023-07-26 08:31:49 +0100
committerJoonas Niilola <juippis@gentoo.org>2023-08-14 14:37:35 +0300
commit1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0 (patch)
tree17d8e33d72893093c945787c317cf0a35182e522 /games-engines
parentnet-im/telegram-desktop-bin: add 4.8.9 (diff)
downloadgentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.tar.gz
gentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.tar.bz2
gentoo-1589d8355d6232cb1e8b21e8ae3a3be8acf6f2b0.zip
games-engines/openmw: enable lua5-1, lua5-3, lua5-4
But only on arches which don't support luajit Signed-off-by: Alexey Sokolov <alexey+gentoo@asokolov.org> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/openmw/openmw-0.48.0.ebuild10
-rw-r--r--games-engines/openmw/openmw-9999.ebuild10
2 files changed, 14 insertions, 6 deletions
diff --git a/games-engines/openmw/openmw-0.48.0.ebuild b/games-engines/openmw/openmw-0.48.0.ebuild
index a7b997f5b8a9..53fd00d2a2fe 100644
--- a/games-engines/openmw/openmw-0.48.0.ebuild
+++ b/games-engines/openmw/openmw-0.48.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-LUA_COMPAT=( luajit )
+LUA_COMPAT=( lua5-{1,3,4} luajit )
inherit cmake lua-single readme.gentoo-r1 xdg
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
@@ -105,8 +105,6 @@ src_configure() {
-DUSE_LUAJIT=ON
)
else
- # 5.1 (and other 5.x) are supported in theory, but don't work well (eg. test fails)
- # In a future version consider adding it back to LUA_COMPAT or dropping this branch
mycmakeargs+=(
-DUSE_LUAJIT=OFF
-DLua_FIND_VERSION_MAJOR=$(ver_cut 1 $(lua_get_version))
@@ -137,6 +135,12 @@ src_compile() {
}
src_test() {
+ # Lua 5.x is supported in theory, but don't work as well, the test fails
+ # Upstream recommends luajit, but it has less arch coverage
+ if [[ ${ELUA} != luajit ]]; then
+ elog "Skipping tests on ${ELUA}"
+ return
+ fi
pushd "${BUILD_DIR}" > /dev/null || die
./openmw_test_suite || die
popd > /dev/null || die
diff --git a/games-engines/openmw/openmw-9999.ebuild b/games-engines/openmw/openmw-9999.ebuild
index a7b997f5b8a9..53fd00d2a2fe 100644
--- a/games-engines/openmw/openmw-9999.ebuild
+++ b/games-engines/openmw/openmw-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-LUA_COMPAT=( luajit )
+LUA_COMPAT=( lua5-{1,3,4} luajit )
inherit cmake lua-single readme.gentoo-r1 xdg
DESCRIPTION="Open source reimplementation of TES III: Morrowind"
@@ -105,8 +105,6 @@ src_configure() {
-DUSE_LUAJIT=ON
)
else
- # 5.1 (and other 5.x) are supported in theory, but don't work well (eg. test fails)
- # In a future version consider adding it back to LUA_COMPAT or dropping this branch
mycmakeargs+=(
-DUSE_LUAJIT=OFF
-DLua_FIND_VERSION_MAJOR=$(ver_cut 1 $(lua_get_version))
@@ -137,6 +135,12 @@ src_compile() {
}
src_test() {
+ # Lua 5.x is supported in theory, but don't work as well, the test fails
+ # Upstream recommends luajit, but it has less arch coverage
+ if [[ ${ELUA} != luajit ]]; then
+ elog "Skipping tests on ${ELUA}"
+ return
+ fi
pushd "${BUILD_DIR}" > /dev/null || die
./openmw_test_suite || die
popd > /dev/null || die