summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-04 17:24:14 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-09 16:25:41 +1000
commit01ba4dc61965ef7658a24728841c04c9a1ce4871 (patch)
treea2a6b927779e5990ff87ec4589373d1d89129a63 /games-emulation
parentprofiles: mask dev-lang/starlark-rust (diff)
downloadgentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.gz
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.tar.bz2
gentoo-01ba4dc61965ef7658a24728841c04c9a1ce4871.zip
*/*: update for slotted Rust
Tidyups: - $(cargo_crate_uris) - Rust BDEPENDS come from the eclass except in very rare circumstances (RUST_OPTIONAL=1) - RUST_M{AX,IN}_VER where required. - Suboptimal crate separator (`-` -> `@`) Signed-off-by: Matt Jolly <kangie@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/39218 Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/rmg/rmg-0.6.5-r1.ebuild (renamed from games-emulation/rmg/rmg-0.6.5.ebuild)3
-rw-r--r--games-emulation/rmg/rmg-0.6.6-r1.ebuild (renamed from games-emulation/rmg/rmg-0.6.6.ebuild)3
-rw-r--r--games-emulation/rmg/rmg-9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/games-emulation/rmg/rmg-0.6.5.ebuild b/games-emulation/rmg/rmg-0.6.5-r1.ebuild
index 6ca37bec7198..48350becfcc2 100644
--- a/games-emulation/rmg/rmg-0.6.5.ebuild
+++ b/games-emulation/rmg/rmg-0.6.5-r1.ebuild
@@ -71,7 +71,7 @@ RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
dynarec? ( dev-lang/nasm )
- rust-plugin? ( virtual/rust )
+ rust-plugin? ( ${RUST_DEPEND} )
"
PATCHES=(
@@ -80,6 +80,7 @@ PATCHES=(
pkg_setup() {
QA_FLAGS_IGNORED="/usr/$(get_libdir)/RMG/Plugin/Input/libmupen64plus_input_gca.so"
+ rust_pkg_setup
}
src_unpack() {
diff --git a/games-emulation/rmg/rmg-0.6.6.ebuild b/games-emulation/rmg/rmg-0.6.6-r1.ebuild
index 6ca37bec7198..eed49326ebd4 100644
--- a/games-emulation/rmg/rmg-0.6.6.ebuild
+++ b/games-emulation/rmg/rmg-0.6.6-r1.ebuild
@@ -71,7 +71,7 @@ RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
dynarec? ( dev-lang/nasm )
- rust-plugin? ( virtual/rust )
+ rust-plugin? ( ${RUST_DEPEND} )
"
PATCHES=(
@@ -80,6 +80,7 @@ PATCHES=(
pkg_setup() {
QA_FLAGS_IGNORED="/usr/$(get_libdir)/RMG/Plugin/Input/libmupen64plus_input_gca.so"
+ use rust-plugin && rust_pkg_setup
}
src_unpack() {
diff --git a/games-emulation/rmg/rmg-9999.ebuild b/games-emulation/rmg/rmg-9999.ebuild
index 6ca37bec7198..48350becfcc2 100644
--- a/games-emulation/rmg/rmg-9999.ebuild
+++ b/games-emulation/rmg/rmg-9999.ebuild
@@ -71,7 +71,7 @@ RDEPEND="${DEPEND}"
BDEPEND="
virtual/pkgconfig
dynarec? ( dev-lang/nasm )
- rust-plugin? ( virtual/rust )
+ rust-plugin? ( ${RUST_DEPEND} )
"
PATCHES=(
@@ -80,6 +80,7 @@ PATCHES=(
pkg_setup() {
QA_FLAGS_IGNORED="/usr/$(get_libdir)/RMG/Plugin/Input/libmupen64plus_input_gca.so"
+ rust_pkg_setup
}
src_unpack() {