summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 10:50:10 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 11:11:20 +0200
commit24dfb421738b1d343d1d9a4c1cb72ffdcaf4f059 (patch)
tree3e5dba24956189752550fe5bc2d7a03c33161317 /games-arcade/aop/aop-0.6-r1.ebuild
parentgames-arcade/amphetamine: Drop old (diff)
downloadgentoo-24dfb421738b1d343d1d9a4c1cb72ffdcaf4f059.tar.gz
gentoo-24dfb421738b1d343d1d9a4c1cb72ffdcaf4f059.tar.bz2
gentoo-24dfb421738b1d343d1d9a4c1cb72ffdcaf4f059.zip
games-arcade/aop: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'games-arcade/aop/aop-0.6-r1.ebuild')
-rw-r--r--games-arcade/aop/aop-0.6-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-arcade/aop/aop-0.6-r1.ebuild b/games-arcade/aop/aop-0.6-r1.ebuild
new file mode 100644
index 000000000000..751bc0e7fd13
--- /dev/null
+++ b/games-arcade/aop/aop-0.6-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Ambassador of Pain is a curses based game with only 64 lines of code"
+HOMEPAGE="http://raffi.at/view/code/aop"
+SRC_URI="http://www.raffi.at/code/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s#/usr/local/share#${GAMES_DATADIR}#" \
+ aop.c || die
+ eapply "${FILESDIR}"/${P}-as-needed.patch
+}
+
+src_install() {
+ dobin aop
+ insinto "/usr/shate/${PN}"
+ doins aop-level-*.txt
+ einstalldocs
+}